PDA

View Full Version : Passing Custom Propery and temp file path to log in command line paramters.



sureshkottakki
01-21-2015, 08:23 AM
Hi,

We are using Suite installers to package the individual installers and we are passing command line parameters to suppress language pop-up, our own property and temp file path to create the log files.

The below command line is not working. I was using backslash to escape the double quotes. The log file is not getting created.

/L[ISSelectedLanguage] /v"/l*v \"%TEMP%\NMS.Platform.Installer.log\"" /v"MyProperty=true"

If we hardcode the path for log files it is working fine.

/L[ISSelectedLanguage] /v"/l*v C:\test.log" /v"MyProperty=true"

MichaelU
01-21-2015, 09:24 AM
Instead of %TEMP%, use [TempFolder], or possibly [%TEMP] in your package command line.

That said, it looks like you're using a Suite EXE package to install a .msi file; I'm obligated to point out that we prefer using the Suite's Windows Installer package to install .msi files, at which point the Enable Logging Support settings can control this more directly.

sureshkottakki
01-22-2015, 02:20 AM
Thanks a lot Michael, it is working grt