PDA

View Full Version : COM objects and their DLL's???



ftherrmann
12-15-2014, 07:43 PM
I've seen a number of posts concerning this but nothing that I've been able to use to fix my problem. I've also taken a quick look at the faq and knowledge base.

I’m having problems with dependent dll files. I can create a setup file, install the application and run the application on my development system. However the installed application will not run on my test machine that has the required end user installed applications, but not the development tools (VS2013).

My assumption (correctly or incorrectly) is that InstallShield is smart enough to look at the resources used in the VS solution and then incorporate them into the installer. Is this correct?

Example from your log file:

MaxIm_DL.exe, or one of its dependencies of component CCDBot.Primary_output
ISEXP : warning -6248: Could not find dependent file FocusMax.exe

Both Maxim_DL.exe and FocusMax.exe are owned by other developers and I obviously cannot distribute them with my app. These are products that the end user must have installed prior to the use of my app.

Most, if not all, of the dll’s do show up in the install directory. However they show up with the “Interop” prefix. Why is this?

I do know that I have a number of cast issues within my app when the “strict” option is turned on. However the app compiles and runs fine with “strict” turned off. Some of these issues also include “Interop” casting which at this point I do not understand.

I’ve attached the log file along with a screen grab of the install directory.

Could you please advise me as to how I can fix this?

Thank you,

Fred Herrmann
10670

GrantK
12-19-2014, 04:19 PM
You are most likely missing a Prerequisite install. Find out what dll's are missing, then find out what 3rd party install installs these dll files, then include the appropriate prerequisite into your project.

Grant