PDA

View Full Version : Database Migration Issue



schappy
11-25-2014, 11:44 AM
We are using AdminStudio 10 and have the need to migrate the AdminStudio Catalog and AdminStudio Compatibilty Solver databases to a new server. We migrated the databases and setup the appropriate database accounts on the new server. When I launch AdminStudio 10 client and attempt to connect to the catalog in its new location (we do Standalone), I get the following message:

10652

I am getting a connection to the database as hitting the 'Test' button says the test connection succeeded.

Has anyone seen this error and know of a resolution? I changed the sql database name in the Shared AdminStudio.ini file and still receive the same error.

Thank you.

schappy
11-25-2014, 02:32 PM
Our DBA found the issue it appears. The asadmin account had not been made an owner on the database. It appears that we are back in business.

cris_fletcx
12-09-2014, 09:58 AM
Our DBA found the issue it appears. The asadmin account had not been made an owner on the database. It appears that we are back in business.
You just re-create an account and that's all?

Evan Border
12-09-2014, 01:23 PM
You just re-create an account and that's all?

There was no need to re-create any account. The problem was that the account being used had insufficient rights to the AdminStudio Application Catalog database, so the solution was to increase the rights. In their case, they chose to provide db_owner rights to Application Catalog database. That's fine, but it's actually more than the required rights. The required database rights are:
db_datareader
db_datawriter
alter
execute

db_owner grants all of the above rights and then some. We have a Flexera Software HelpNet article that shows how to apply the above permissions:
http://helpnet.flexerasoftware.com/epi/Content/helplibrary/EPI_ASDBPerm.htm