PDA

View Full Version : Uinux Installer Issues - Install log not created, No install progress messages ...



Amarjit Jutla
11-13-2014, 12:25 PM
Hello:

We ported a Unix IA 2010 project with Console and Silent mode to IA 2104 and have noticed the following:

1. Unix silent mode install
- Install log file does get generated
- Install progress not indicated (previous we had some show that install project was loading and we got a progress meter)
- with 2014 nothing is shown - the install just returns with no message (does seem to install properly though)

2. Unix console mode
- Install log file does get generated
- Install progress with progress meter is indicated as with IA 2010.

Any body experienced the same behavior and the have fix for this?

Thanks
Amarjit

Amarjit Jutla
11-13-2014, 10:07 PM
Sorry - noticed the following

1. Unix SILENT mode install
- Install log file does NOT get generated
- Install progress NOT indicated (previous we had some show that install project was loading and we got a progress meter)
- with 2014 nothing is shown - the install just returns with no message (does seem to install properly though)

2. Unix CONSOLE mode
- Install log file does NOT get generated
- Install progress with progress meter IS indicated as with IA 2010.

Amarjit Jutla
11-14-2014, 12:41 PM
Running the converted (from IA 2010 to 2014) Unix Installer project in debug mode, revealed the following.

I/O error occured writing additional files list
java.io.FileNotFoundException: null/removablesList.txt (No such file or directory)
at java.io.FileOutputStream.open(Native Method)
at java.io.FileOutputStream.<init>(Unknown Source)
at java.io.FileWriter.<init>(Unknown Source

This is related to Uninstaller component - we did not have an uninstaller in the IA 2010 project, but it seems we need one now. Introducing a Uninstaller got rid of the above error and allowed the Installation to run to completion, which also then created the Install logs (but in the Install folder, not in the folder I had specified).

Anyways problem of the install log file creation is cleared up now. :)

There install progress with silent install still does not show - has this been removed in 2014?

Installing...
-------------

[==================|==================|==================|==================]
[------------------|------------------