PDA

View Full Version : Suite dialog backgrounds



JBeauvais
10-28-2014, 05:29 PM
I am having difficulties with using brushes that contain images in suite wizard pages. In IS2012, I had 3 images - header, body and footer. They filled the entire dialog box as they were supposed to and looked like a seamless graphic. In IS2014, the header is offset from the body (raised up) and a different width than the body. I have yet to have the footer show up under the navigation buttons.

I also tried using a single file instead and it smooshed everything together into the body area only. I had assumed it would expand to fill the entire dialog box. Is that not the case? The header and footer contain default colors. Any ideas of what I have set up incorrectly?

MichaelU
10-29-2014, 08:35 AM
To use a single image as your background, make sure that you've specified the image for Full Wizard Background, and left Default Body Background, Header Background, and Navigation Background set to "(No Style)".

(The same behavior was only recently made available in the IDE; previously it was available only through edits to the project file that were described in this InstallTalk blog post (http://blogs.flexerasoftware.com/installtalk/2011/10/using-styles-to-customize-the-user-interface-of-a-suite-installation.html). Due to changes in the XML schema they may look a little different today.)

JBeauvais
10-29-2014, 02:13 PM
I tried what the InstallTalk blog said to do in IS2012 just see how it worked with the old XML format. I could not get it to work there at all. Nothing showed up as the background. Snippets from the .issuite:
<ImageBrush Name="Body" Resource="installer_body_empty_full.jpg"/>

<Wizard Format="Aero" Caption="IDS_PRODUCTNAME_INSTALLSHIELD" Icon="IS.ico" Resize="0" Header.Class="Header" View.Margin="false" View.Height="225" View.Width="400" Background="Body" View.Transition="true" Navigation.Spacing="group" Navigation.Direction="RTL" Navigation.Margin.cx="10">


In IS2012 using 3 images (header, body & footer) everything looked good.
10635

<ImageBrush Name="Header" Resource="installer_header.jpg"/>
<ImageBrush Name="Body" Resource="installer_body_empty.jpg"/>
<ImageBrush Name="Footer" Resource="installer_footer.jpg"/>

<Wizard Format="Aero" Caption="IDS_PRODUCTNAME_INSTALLSHIELD" Icon="IS.ico" Resize="0" Header.Background="Header" Header.Class="Header" View.Margin="false" View.Height="225" View.Width="400" View.Background="Body" View.Transition="true" Navigation.Spacing="group" Navigation.Direction="RTL" Navigation.Background="Footer" Navigation.Margin.cx="10">


In IS2014 using the full wizard background, the header and footer are not showing the graphic that should fill the dialog.
10637

<ImageBrush Name="Body" Resource="installer_body_empty_full.jpg"/>

<Wizard Format="Glass" Caption="IDS_PRODUCTNAME_INSTALLSHIELD" Resize="0" Background="Body">
<Wizard.Header Class="Header"/>
<Wizard.View Margin="false" Height="225" Width="400" Transition="true"/>
<Wizard.Navigation Spacing="group" Direction="RTL" Margin="10" Class="Body"/>


I also tried IS2014 using my 3 images (header, body & footer). Again, the header and footer graphics are not displayed. It looks the same as the previous picture.
<ImageBrush Name="Header" Resource="installer_header.jpg"/>
<ImageBrush Name="Body" Resource="installer_body_empty.jpg"/>
<ImageBrush Name="Footer" Resource="installer_footer.jpg"/>

<Wizard Format="Glass" Caption="IDS_PRODUCTNAME_INSTALLSHIELD" Resize="0">
<Wizard.Header Class="Header" Background="Header"/>
<Wizard.View Margin="false" Height="225" Width="400" Background="Body" Transition="true"/>
<Wizard.Navigation Spacing="group" Direction="RTL" Margin="10" Class="Body" Background="Footer"/>

I obviously still have something wrong in the .issuite, but no matter what I change, it just doesn't work right.

By the way, while in the IDE, the dialogs look correct. All of the graphics (header, body & footer) are visible, but when I run the Suite, the graphics are wrong.

MichaelU
10-30-2014, 10:50 AM
When the wizard is in Glass mode, neither the header nor footer's background are visible. Setting your Wizard Format to Wizard97 will address this aspect, and the run-time and preview behavior should be more similar.

JBeauvais
10-30-2014, 11:37 AM
Thank you, thank you, thank you! That took care of the entire problem.