PDA

View Full Version : devenv.exe build fails w/ error : -6225: Resolving Visual Studio .NET project output



daves1
10-20-2014, 11:01 AM
Greetings,

I have an installshield project that builds fine from within Visual Studio but when I attempt to build it from the command line, it fails with:

ISDEV : error : -6225: Resolving Visual Studio .NET project output "MyProject\MyProject.csproj\|Built"

I attempted to use msbuild, but our app uses WPF which causes other issues with InstallShield when resolving xaml references.

I was able to automate building all of the other components in a separate msbuild script and that completes successfully. Adding in the installshield project has been resulting in much grief.

I'm not sure how to solve this.

This is the command I'm using:

devenv c:\code\mySolution\src\MySolution.sln /build "Release|x64"

Any assistance would be appreciated.

hidenori
10-20-2014, 11:38 AM
Check this post (https://community.flexerasoftware.com/showthread.php?206022-6225-Resolving-Visual-Studio-NET-project-output&highlight=devenv) out.

daves1
10-22-2014, 07:13 AM
I can use msbuild to build everything else without issue but when I build the installer it dies. We have WPF in our solution and references to the xaml files are not compiling:

\Views\Includes\_DocumentViewPanel.xaml(306,41): error MC3066: The type reference cannot find a public type named 'Node'. Line 306 Position 41. [my.csproj]
\Views\DocumentDialog.xaml(160,45): error MC3066: The type reference cannot find a public type named 'Node'. Line 160 Position 45. [my.csproj]
\Views\Includes\_DragDropDictionary.xaml(10,10): error MC3074: The tag 'NameTextControl' does not exist in XML namespace 'http://schemas.devexpress.com/winfx/2008/xaml/grid'. Line 10 Position 10. [my.csproj]
\Views\MainWindow.xaml(199,46): error MC3074: The tag 'TreeListDragDropManager.DragElementTemplate' does not exist in XML namespace 'http://schemas.devexpress.com/winfx/2008/xaml/grid'. Line 199 Position 46. [my.csproj]
Done Building Project "my.csproj" (Build target(s)) -- FAILED.

Another problem here is that everything was previously built so it should NOT be rebuilding the dependent projects.