PDA

View Full Version : Request: Change inaccurate description of "Overwrite Any Existing File" check box.



scottd72
10-14-2014, 03:15 PM
This post is pertaining the QuickPatch project file. I wasted hours on an issue as a result of a very inaccurate description for a check box in the QuickPatch project file.

In the QuickPatch IDE, "Files" view, on the right is the "Updated File" section. Just below the text field is a checkbox with a pretty good and lengthy description about what it does:
"Overwrite Any Existing File - Select this option to include this file into your setup as a whole file. This will allow you to patch over any previous version of the file. Non-versioned files will always overwrite when this option is selected." I read this description and thought, "this is exactly what I need!" In my situation, the file I need to update has a version of 17.0.0.0, and the latest file has the same version. I thought it was a slam dunk. But the file would not update. I spent so much time trying different things and doing google searches. Finally I stumbled upon the documentation for this checkbox http://helpnet.installshield.com/installshield18helplib/QPAppFileModifiedCommonTab.htm. It says that when this option is selected, Windows Installer considers the selected file to have a version of 1.0.0.0, and the file with the highest version wins. This is ONLY useful if both the target and selected file are unversioned.

This check box description is very misleading and inaccurate, and hopefully someone from Installshield will change it to save some other user a lot of time and frustration.

DebbieL
10-15-2014, 10:42 AM
Ah, I'm sorry about the confusion! We'll change the name of the field from Overwrite Any Existing File to Include Whole File. Thanks for reporting the problem.