PDA

View Full Version : Installer fails to install uninstaller



rpetti
09-18-2014, 06:49 PM
I've recently updated to IA2014 from 2012, and am having a serious issue with the installation failing to install the uninstaller:


Install Uninstaller: ProductName(Install All Uninstaller Components)
Status: ERROR
Additional Notes: ERROR - Error installing uninstaller: java.lang.NullPointerException


The console log shows the following:


java.lang.NullPointerException
at com.zerog.ia.installer.actions.InstallUninstaller.bv(Unknown Source)
at com.zerog.ia.installer.actions.InstallUninstaller.installSelf(Unknown Source)
at com.zerog.ia.installer.InstallablePiece.install(Unknown Source)
at com.zerog.ia.installer.actions.InstallDirectory.install(Unknown Source)
at com.zerog.ia.installer.InstallablePiece.install(Unknown Source)
at com.zerog.ia.installer.GhostDirectory.install(Unknown Source)
at com.zerog.ia.installer.InstallablePiece.install(Unknown Source)
at com.zerog.ia.installer.Installer.install(Unknown Source)
at com.zerog.ia.installer.actions.InstallProgressAction.ae(Unknown Source)
at com.zerog.ia.installer.actions.ProgressPanelAction$1.run(Unknown Source)


After installation, the uninstaller folder contains the zerog registry and the uninstaller executable, but uninstaller.jar is 0 bytes in size. When I try to launch the uninstaller executable, I get:


Could not find the main class: com.zerog.lax.LAX. Program will exit.


This happens on all platforms I've tried. Any help would be greatly appreciated!

philippejamet
09-23-2014, 08:25 AM
I have exactly the same problem
I've recently updated to IAW-2014 from IAW-2013, and I had the same serious issue with the installation failing to install the uninstaller
Could you help me ?

rpetti
10-02-2014, 06:14 PM
We managed to narrow down the issue to the feature selection panels, or rather, the lack of them. If you remove all of the feature selection panels both from the Pre-Install and Pre-Uninstall phases, this issue will occur. An install that only has one feature set as the default should not require these panels, so it seems perfectly reasonable that the user should be able to remove them without causing runtime issues.

I was able to get around the problem by adding the “Choose Uninstall Type: Uninstall Options” and the “Choose Features to Uninstall: Choose Product Features” panels and consoles to the Pre-Uninstall phase, and adding a rule to all of them that always resolves to false. This will allow the installer to install the uninstaller, while still behaving in the same way.

sturge
10-07-2014, 02:00 PM
Thanks for finding this!

etdevel1
01-17-2015, 01:30 AM
I ran into the same issue after upgrading to IA 2014 Pro, but for me the fix was to update the version of Java installed on the target system (from 1.6 to 1.7).

--ET