View Full Version : Major upgrade leaves old version in add/remove list

09-08-2014, 08:21 AM
I’m making a major upgrade. I have changed the product code but left upgrade code untouched. When I try to install the new installer on previous version (which is already installed on the target machine) the previous version is left in Windows’ Programs and Features list (i.e. “Add remove programs”). The only difference is that it has no icon. Well, it has an icon (default icon) but the original custom made icon is gone.

The new installer seems to uninstall the previous version since I see messages like “Uninstalling previous version” and “Removing shortcuts” during installation of the new version. Shortcuts disappear and I see files being deleted so the new version detects the older version.

I have configured an upgrade path so that all previous versions are major upgraded (i.e. uninstalled before installing the newest version).

Before InstallShield I used Visual Studio’s Setup project and the product version of my product is 6.0.x for Visual Studio Setup projects. They are major upgraded without any problems (e.g. 6.0.5 is upgraded to 6.1.0). The first InstallShield based version is 6.1.0.

I'm trying to delete the related registry key (i.e. so that the previous version disappears from "Programs and Features" list) using a InstallScript custom action but RegDBDeleteKey fails. FormatMessage provides an empty string on RegDBDeleteKey return value. This isn't the best solution since previous version's install files (C:\Program Files x86\InstallShield Installation Information folder) stay on the target system as "garbage".

Does anyone have any ideas what might be causing this? I've seen people complain about the same problem even back in 2008. I hope this isn't the same problem/bug in InstallShield 2014...

09-15-2014, 03:30 AM
Flexera has confirmed that this is a bug in InstallShield 2014 so problem "kinda" solved. Just waiting for the bug fix...

11-04-2014, 02:05 PM
Flexera has confirmed that this is a bug in InstallShield 2014 so problem "kinda" solved. Just waiting for the bug fix...

I know this is somewhat old but - I couldn't find confirmation in their "Known Issues" list. I've encountered the same issue and have been working to see if it's a problem with our installer before removing the old version (registry entry) in the add/remove list.

Did Flexera mail you directly or did you find a post by them elsewhere? I searched the 2014 forums and did not find anything.