PDA

View Full Version : Prerequisite for NET 4.0 fails



Muhanned Maayeh
08-24-2014, 09:36 AM
I am using InstallScript project (Setup EXE -- single image {not MSI}) and included a Microsoft .NET 4.0 Framework Full prerequisite. When the Setup is run then, the prerequisite fails. I am installing on Windows 2008 (R1 not R2) x86 system as a test environment. How can I debug this issue?

Please see error message box:
10583

Note: just to add further information:
1) the prerequisite was downloaded and exists in the standard product folder: C:\Program Files\InstallShield\2014\\SetupPrerequisites\Microsoft .net\4.0\Full\dotNetFx40_Full_x86_x64.exe
2) the prerequisite was embedded in the setup EXE
3) when running the dotNetFx40_Full_x86_x64.exe itself on the machine then the installation succeeds.

update: I have tested on Windows 7 Professional and the same error occurs. Is there a bug in InstallShield that causes embedded prerequisites to fail or something is not being included correctly from my side?

Muhanned Maayeh
08-25-2014, 03:16 AM
I am using InstallScript project (Setup EXE -- single image {not MSI}) and included a Microsoft .NET 4.0 Framework Full prerequisite. When the Setup is run then, the prerequisite fails. I am installing on Windows 2008 (R1 not R2) x86 system as a test environment. How can I debug this issue?

Please see error message box:
10583

Note: just to add further information:
1) the prerequisite was downloaded and exists in the standard product folder: C:\Program Files\InstallShield\2014\\SetupPrerequisites\Microsoft .net\4.0\Full\dotNetFx40_Full_x86_x64.exe
2) the prerequisite was embedded in the setup EXE
3) when running the dotNetFx40_Full_x86_x64.exe itself on the machine then the installation succeeds.

update: I have tested on Windows 7 Professional and the same error occurs. Is there a bug in InstallShield that causes embedded prerequisites to fail or something is not being included correctly from my side?

Well, I found the issue for my case. It turns out in the installation location for the prerequisites (C:\Program Files\InstallShield\2014\SetupPrerequisites\Microsoft .net\4.0\Full, typically) the NET 4.0 Framework was not downloaded completely as indicated by InstallShield 2014 professional. I went back to the "SetupPrerequisites" location and realized that the file size was 192 KB where it should have been approximately 48 MB. Fortunately, I had a previous download on a separate occasion and copied that setup to the "C:\Program Files\InstallShield\2014\SetupPrerequisites\Microsoft .net\4.0\Full" and rebuilt my setup. Now the behavior is correct.

CR2020
09-05-2014, 11:50 AM
Note: just to add further information:
1) the prerequisite was downloaded and exists in the standard product folder: C:\Program Files\InstallShield\2014\\SetupPrerequisites\Microsoft .net\4.0\Full\dotNetFx40_Full_x86_x64.exe



So does this mean I have to copy the entire .NET 4.0 framework into the prereq folder? Mine is not working either and I'm having trouble locating step-by-step directions that actually mirror my installer. I'm using the 2013 IS LE package embedded as a tool within MS Studio 2013.

Muhanned Maayeh
09-09-2014, 12:54 AM
So does this mean I have to copy the entire .NET 4.0 framework into the prereq folder? Mine is not working either and I'm having trouble locating step-by-step directions that actually mirror my installer. I'm using the 2013 IS LE package embedded as a tool within MS Studio 2013.

Yes that is correct, please try copying the .NET 4.0 framework setup into your prereq folder and build the setup again. Hopefully this should work.