PDA

View Full Version : SQL Express 2014 Silent install fails when called from Installshield Prerequisite



Nitin Ghanwat
06-05-2014, 09:40 PM
Hello,

I am upgrading SQL Express 2005 SP4 to SQL Express 2014 by silent install. It installs when I use command line method but when I tried to use same commands in the Installshield prerequisite, it fails.

Commands I am using for upgrade are:
SQLEXPR_x86_ENU.exe.exe /q /ACTION=upgrade /INSTANCENAME=SQLEXPRESS /ISSVCAccount="NT AUTHORITY\SYSTEM" /IACCEPTSQLSERVERLICENSETERMS

Silent commands are also not working when those are launched from Installshield prerequisite for fresh installation of SQL Express 2014.
Commands for fresh installs are:
SQLEXPR_x86_ENU.exe /Q /ACTION=INSTALL /FEATURES=SQL /INSTANCENAME=SQLEXPRESS /SQLSVCACCOUNT="NT AUTHORITY\SYSTEM" /SECURITYMODE=SQL /SAPWD=" " /AGTSVCACCOUNT="NT AUTHORITY\SYSTEM" /TCPENABLED=1 /NPENABLED=1 /IACCEPTSQLSERVERLICENSETERMS

Silent commands provided by MS SQL are working with Installshield prerequisite with SQL express 2005.

To get rid of this , I tried to call a bat file from Installshield prerequisite which will call SQL Express 2014 setup silently but here a empty command window is displayed until installation finishes.

Have others reported this?

Any suggestions of how to silent install SQL Express 2014 from Installshield Prerequisite.

-Thanks

hidenori
06-18-2014, 06:03 PM
Did you check SQL Server setup log files (http://msdn.microsoft.com/en-us/library/ms143702.aspx) for the installation to troubleshoot your issue?

Johannes John
06-20-2014, 03:00 AM
Hello Nitin,

do you have select the prereq to be executed at the beginning or is the prereq feature dependant?

Regards
Johannes

Nitin Ghanwat
06-20-2014, 04:46 AM
Hi John,

I am executing prrequisites before feature execution.

-Nitin

Johannes John
06-20-2014, 06:23 AM
We have problems with newer MS setups, when include in prereques which are executed in feature dependance.

hidenori
06-20-2014, 12:02 PM
Have you checked Microsoft KB 2820068 (http://support.microsoft.com/kb/2820068)?

Nitin Ghanwat
06-20-2014, 11:02 PM
Hello Hidenori,

Thanks for you reply.
I went through the link suggested by you and used "SQLEXPR_x86_ENU.exe /SkipInstallerRunCheck..." but no luck, it is failing at the extraction of the setup.


Following is the log I see
[2014-06-21T09:13:14.161+05:30]: === Logging started: 2014/06/21 09:13:14 ===
[2014-06-21T09:13:14.161+05:30]: Executable: C:\Build\Build\PROJECT_ASSISTANT\SINGLE_EXE_IMAGE\DiskImages\Disk1\ISSetupPrerequisites\{BA6CCDBA-B43D-417D-9F28-89988A3DB2AB}\SQLEXPR_x86_ENU.exe v12.0.2000.8
[2014-06-21T09:13:14.161+05:30]: Computer : MY-PC
[2014-06-21T09:13:14.161+05:30]: --- logging level: standard ---
[2014-06-21T09:13:14.161+05:30]: Successfully bound to the ClusApi.dll
[2014-06-21T09:13:14.161+05:30]: Cannot open the current cluster
[2014-06-21T09:13:14.161+05:30]: Cluster drive map: ''
[2014-06-21T09:13:14.161+05:30]: Directory 'C:\Build\Build\PROJECT_ASSISTANT\SINGLE_EXE_IMAGE\DiskImages\Disk1\ISSetupPrerequisites\{BA6CCDBA-B43D-417D-9F28-89988A3DB2AB}\SQLEXPR_x86_ENU\' has been selected for file extraction
[2014-06-21T09:13:14.161+05:30]: Extracting files to: C:\Build\Build\PROJECT_ASSISTANT\SINGLE_EXE_IMAGE\DiskImages\Disk1\ISSetupPrerequisites\{BA6CCDBA-B43D-417D-9F28-89988A3DB2AB}\SQLEXPR_x86_ENU\
[2014-06-21T09:13:14.738+05:30]: Error 0x80004005: Failed to extract all files out of box container #0.
[2014-06-21T09:13:14.738+05:30]: Error 0x80004005: Failed to extract
[2014-06-21T09:13:14.738+05:30]: Extraction failed.
[2014-06-21T09:13:14.738+05:30]: Exiting with result code: 0x80004005
[2014-06-21T09:13:14.738+05:30]: === Logging stopped: 2014/06/21 09:13:14 ===

hidenori
06-23-2014, 09:34 AM
SQLEXPR_x86_ENU.exe is a self-extract executable and it looks like that it failed to extract the contents due to a path length limitatiion. If you copy your setup to a shorter path such as "C:\Test" and launch it from there, does the problem still occur?

nitsev
01-07-2015, 05:35 AM
SQLEXPR_x86_ENU.exe is a self-extract executable and it looks like that it failed to extract the contents due to a path length limitatiion. If you copy your setup to a shorter path such as "C:\Test" and launch it from there, does the problem still occur?

By default, running the SQLEXPR_x86_ENU.exe will prompt you with a dialog where the files are to be extracted, if you run from a read only medium such as a DVD-rom the suggested path would be something like C:\3e0cf4f2988c72a1dd255526b5e40b\. However, if you run the file from a local drive such as the temp folder, the suggested path will be the same path as the SQLEXPR_x86_ENU.exe is in, which could be significantly longer.
Why the installer in this case does not extract to a folder similar to c:\xxxxx is beyond me. Because, if the path is too long the installation will fail and the summary.txt log file will say something like
"SQL Server installation media on a network share or in a custom folder can cause installation failure if the total length of the path exceeds 260 characters. To correct this issue, utilize Net Use functionality or shorten the path name to the SQL Server setup.exe file." - Hmm 2015 and path length is still an issue AARRGGH!!.

However, there is an argument that you can pass to SQLEXPR_x86_ENU.exe that will replace the automatically generated path so you can type SQLEXPR_x86_ENU.exe /X:"%temp%\SQLEXPRESS" to have the content extracted to the users temp folder instead. The extract dialog is still displayed but the path is now replaced with the temp folder. Ah, problem solved you think, well think again, because passing the /X parameter will simply extract the contents and not launch the installation setup.exe once the files are extracted. Stupid beyond belief.

/Fredrik

dana_lizuca
02-03-2015, 12:08 AM
Hi,

Did anyone find a solution to this?

I am having the same issue here, with the path (<user_temp_folder>\<random_GUID>\Microsoft SQL Server 2014 Express\SQLEXPR_x86_ENU\x86) being too long.

If I package the prerequisite into the installer it works, but I don't really want that, as it will make my installer way too big.

So I have set the prerequisite in InstallShield to download the file "SQLEXPR_x86_ENU.exe" from the Microsoft Downloads (http://download.microsoft.com/download/E/A/E/EAE6F7FC-767A-4038-A954-49B8B05D04EB/Express%2032BIT/SQLEXPR_x86_ENU.exe).

The file gets downloaded into the user's %temp% folder - inside a sub-folder with a random GUID name - which causes the SQL Server install to fail. Is there a way to configure in InstallShield the location of the downloaded file(s)?

Cheers!
Dana

c.l.k.
06-15-2015, 11:31 AM
Hi,

Did anyone find a solution to this?

Dana

hi,

To solve failed extraction problem, you just have to add this paramter into your command line : /q /x:c:\SQL

/x can't be used with /QS value and "c:\sql" is just an example

But after this, you will have another problem !!! the famous "bootstrapping" and /SkipInstallerRunCheck doesn't work.with installshield (or i don't know how to do)

the only way is to create an Aui suite setup but for me it's a nightmare !

Nick Umanski
01-06-2016, 05:57 AM
This sounds similiar to a problem I had with SQLExpress 2012.

As someone suggested earlier the solution is with the parameter SkipInstallerRunCheck=1

However, instead of passing this as a parameter to the SQLEXP prerequisite, you need to set this as a property in the installer calling the prerequisite.

javerson
05-05-2016, 08:54 AM
Did anyone find a solution to this?

For me is giving the following error:

05/04/2016 16:21:14.873 ======================================================================
05/04/2016 16:21:14.881 Setup launched
05/04/2016 16:21:14.887 Attempting to determine media source
05/04/2016 16:21:14.890 Media source value not specified on command line argument.
05/04/2016 16:21:14.892 Setup is launched from media directly so default the value to the current folder.
05/04/2016 16:21:14.893 Media source: C:\Users\W7\AppData\Local\Temp\{1C2AC8B6-F2F3-4866-9F3E-C75F4AC8410A}\{651D8985-1F7B-4867-8AF6-86082D34F0DF}\SQLEXPR_x86_ENU\
05/04/2016 16:21:14.896 Attempt to determine media layout based on file 'C:\Users\W7\AppData\Local\Temp\{1C2AC8B6-F2F3-4866-9F3E-C75F4AC8410A}\{651D8985-1F7B-4867-8AF6-86082D34F0DF}\SQLEXPR_x86_ENU\mediainfo.xml'.
05/04/2016 16:21:15.188 Media layout is detected as: Core
05/04/2016 16:21:15.191 Media is a slipstream package
05/04/2016 16:21:15.193 Only patch related actions can run patch setup.exe, so continuing to run setup.exe from media.
05/04/2016 16:21:15.217 Error: This OS is not supported
05/04/2016 16:21:15.226 SQM key not found
05/04/2016 16:21:15.231 Setup closed with exit code: 0x84C40034
05/04/2016 16:21:15.238 ======================================================================

Ive searched all over the internet but everybody is saying that is not possible this configuration.
Could someone help me?
Thank you