PDA

View Full Version : AdminStudio 2013 R2 SCCM Import always creates guid folders in source location



m4ttmcg
05-29-2014, 08:25 PM
Hi,

I am using Adminstudio 2013 R2 Application Manager to manage MSI packages. I have configured the connection to SCCM for importing as applications, this is working fine, apart from the content source location. AdminStudio always creates a folder with a random guid name. Our standard is to use a named folder according to an internal naming standard for each package's content in the SCCM content share.

I have configured the Location To Publish Package in the Distribution Information option section, to \\dfsserver\sccmapps

this appears to work, because the package folders are created in this location, with the guid as the folder name.

Under Import Options -> Application Model Defaults I have trieds setting Content Location under MSI content to \\dfsserver\sccmapps, but this has no effect. Is there something I should be setting here to prevent a guid folder name? some kind of variables like %packagename% %version% or something?

I have reviewed the help here - http://helpnet.installshield.com/adminstudio115sp2/Content/ashelplibrary/ISCSRefDialogOptionsAppModel.htm and it appears something that if this section is blank, guid folders are used. But how would I use this global setting to create a meaningful application name?

jaybee96
06-02-2014, 01:47 AM
You could try the Powershell API solution?
(Not sure if this can be used to "rename" the application.)

Invoke-ASPublish
Use the Invoke-ASPublish command to publish a package to a deployment server, such as System Center 2012
Configuration Manager, Citrix XenApp Server, Symantec Altiris Server, or AirWatch Server. For publishing, an
ApplicationID is needed instead of a PackageID.

Tip • If you have the PackageID, you can determine the ApplicationID by using the Get-ASApplicationID
command.



http://helpnet.flexerasoftware.com/adminstudio2013r2/Content/ashelplibrary/ASplatform_Invoke_ASPublish.htm