PDA

View Full Version : Error -6003 & -7066



Googoohead
05-16-2014, 11:49 PM
Hi,

I'm upgrading a project from IS2012 to IS2014. When I attempt to generate a Release, I get the following error messages:

ISDEV : error -6003: An error occurred streaming 'C:\Program Files (x86)\InstallShield\2014\SetupPrerequisites\Windows Installer 3.0.prq' into setup.exe

ISDEV : error -7066: Your project contains a reference to the InstallShield prerequisite C:\Program Files (x86)\InstallShield\2014\SetupPrerequisites\Windows Installer 3.0.prq; however, this file cannot be located. Either remove the InstallShield prerequisite from your project, or locate this file.

How can I get rid of these messages? Why is it looking for Installer 3.0?

Thanks,

Rene.

Roman1
05-17-2014, 02:38 PM
Check out this prereq. Or copy them from 2012 installation folder.

Googoohead
05-17-2014, 02:45 PM
I can copy them from the IS2012 folder.

I'm installing Windows Installer 4.5 with my project. How can I stop it from looking for Windows Installer 3.0?

Thanks,

Rene.

DLee65
05-21-2014, 08:45 AM
Rene,

I suspect that some other prerequisite automatically selected the Windows Installer 3.0 prerequisite for you. I think I get this when I select the .NET Framework 3.5 sp1 prerequisite. It is because the Windows Installer 3.0 is listed as a dependency. Just go through the list of selected PRQ files and remove the entry.

If it is not visible to you in the redistributables view, then use direct editor to remove the references. There should be several for the different operating systems.

I do not have the IDE in front of me right now but if you search for the prq name you should find it.