PDA

View Full Version : InstallAnywhere and proxy servers



jpghafary
05-09-2014, 07:37 AM
I am trying to automate the creation of installers using ant task. Each time we launch the ant build, it gets stuck on the step: Looking up Update Service knowing that I am using InstallAnywhere 2103 behind a proxy server. At this step a dialog box (image below) is displayed requiring the entry of the proxy's user name and password. The build is then paused, and won't resume until this dialog is closed.

I have noticed also the same behavior each time I need to launch InstallAnywhere (GUI).

Is there anyway to bypass this behavior? Save the proxy credentials somewhere in a .properties file maybe?!

Thanks for all the replies.

10498

NigelM
08-12-2014, 03:27 PM
I am trying to automate the creation of installers using ant task. Each time we launch the ant build, it gets stuck on the step: Looking up Update Service knowing that I am using InstallAnywhere 2103 behind a proxy server. At this step a dialog box (image below) is displayed requiring the entry of the proxy's user name and password. The build is then paused, and won't resume until this dialog is closed.

I have noticed also the same behavior each time I need to launch InstallAnywhere (GUI).

Is there anyway to bypass this behavior? Save the proxy credentials somewhere in a .properties file maybe?!

Thanks for all the replies.

10498

I do not know much about the Ant task, but build.exe takes a -nupd argument that prevent s the call to the update service. May be the Ant task allows you to specify command-line options for the invoked build?

dkasberg
11-03-2014, 03:23 PM
NigelM, were you able to get past this issue? I'm running into the same problem on IA 2012, but that command-line option doesn't seem to make a difference.

NigelM
01-30-2015, 04:36 PM
NigelM, were you able to get past this issue? I'm running into the same problem on IA 2012, but that command-line option doesn't seem to make a difference.

They gave me a patch at the time when I reported this in IA2012, it was included in the base IA2013 release.

varamo
02-06-2015, 04:03 PM
They gave me a patch at the time when I reported this in IA2012, it was included in the base IA2013 release.

Thanks to NigelM for pointing to at least "-nupd" option.
With this key, I was able to find this option for build.xml file which helps to prevent UpdateService invocation for each build.

<target name="timesten" depends="custom-code">
<buildinstaller
IALocation="${ia.dir}"
IAProjectFile="timesten.iap_xml"
BuildWorkdirLocation="build"
failOnError="true"
doNotUploadProfileData="true"/>
</target>

I hope this helps other people who fights with IA updating service :)