PDA

View Full Version : LAX Graphical Launcher Trashes java.library.path setting in LAX properties on Mac



swindham
02-12-2014, 05:13 PM
I setup a LAX Graphical launcher for the Mac version of my installer. When I run the graphical launcher, it is changing my settings for java.library.path. When I set it to do a console launch it works properly. Here is my setting in the LAX properties:

lax.nl.java.option.additional -DtasDir=$USER_INSTALL_DIR$$/$tas -Djava.library.path=$USER_INSTALL_DIR$$/$tas$/$bin

When I run the console launcher, my program tells me the correct value for java.library.path and my JNI libraries load just fine:

tasDir=/Applications/atm/tas
java.library.path=/Applications/atm/tas/bin

When I run the graphical launcher, my program tells me a completely different path that does not include my LAX properties setting and the native libraries fail to load. My program tells me the following about java.library.path:

tasDir=/Applications/atm/tas
java.library.path=/Applications/atm/tas/bin/tas.app/Contents/Resources/Java

In both versions (console and graphical) my tasDir parameter is passed to the program correctly. However in the Graphical launcher, it looks like java.library.path is getting overwritten with the Mac path to the LAX executable.

Is there something else I need to do to get my java.library.path setup properly to run on a Mac?

Thanks,
Steve Windham