PDA

View Full Version : Standalone build error (ISDEV : error -6243: InstallUtilLib.dll cannot be located)



sooraj_er
12-17-2013, 02:08 AM
InstallShield 2013 standalone build is giving the below error after migrating the ism to 2013:
ISDEV : error -6243: InstallUtilLib.dll cannot be located on your system. This file is required for Installer custom actions. You can set the path to InstallUtilLib.dll using Tools | Options and/or specify the path with the -t command line build option. The file is part of the Microsoft .NET Framework redistributable. c:\Windows\Microsoft.NET\Framework\v4.0.3031964\

We are using the below command for the build. Same command works fine with 2010 standalone build and 2010 ism.
"C:\Program Files (x86)\InstallShield\2013\System\IsCmdBld.exe" -p "D:\Projects\RAPIDComm_tfs\Nimrod\Install\src\Setup\Rapidcomm 6.0 Server Debug 64.ism" -a "NotDistributed" -r "CDWinx64" -o "D:\Projects\RAPIDComm_tfs\Nimrod\Install\src\Setup" -b "C:\TestBuilds" -t "C:\WINDOWS\Microsoft.NET\Framework64\v4.0.30319" >> "C:\Setup_server_x64_debug.log"

DLee65
12-17-2013, 01:35 PM
Question: Have you configured the path to your merge modules and prerequisites in your registry for your build machine for 2013? I am not sure if this is the issue you are having but I know that it will have a problem finding source files for them if it is not configured.

Below are the articles that talk about adding the prerequisites to your build machine:

http://helpnet.flexerasoftware.com/installshield20helplib/installshield20helplib.htm#CSHID=helplibrary%2FIncorporatingRedists.htm|StartTopic=Content%2Fhelplibrary%2FIncorporatingRedists.htm
For specifying the prerequisites path:
http://helpnet.flexerasoftware.com/installshield20helplib/installshield20helplib.htm#CSHID=helplibrary%2FIncorporatingRedists.htm|StartTopic=Content%2Fhelplibrary%2FIncorporatingRedists.htm
For specifying the merge module path:
http://helpnet.flexerasoftware.com/installshield20helplib/installshield20helplib.htm#CSHID=helplibrary%2FIncorporatingRedists.htm|StartTopic=Content%2Fhelplibrary%2FIncorporatingRedists.htm

Again, I am not certain that this is the cause of your problems; but it is a good place to start just to be sure. Hopefully it helps. Good luck. *cheers*

sooraj_er
12-17-2013, 11:53 PM
Hi Lee,
Thanks for the reply. I am getting the same error after setting merge modules path in registry. Infact the merge modules are getting added without error. The error occurs while adding custom actions. Below is the sequence from the build log file:

...........
...........
Building scanned MsiAssemblyName records
Adding Installer namespace CustomActions for .NET assemblies
ISDEV : error -6243: InstallUtilLib.dll cannot be located on your system. This file is required for Installer custom actions. You can set the path to InstallUtilLib.dll using Tools | Options and/or specify the path with the -t command line build option. The file is part of the Microsoft .NET Framework redistributable. C:\WINDOWS\Microsoft.NET\Framework64\v4.0.3031964\
ISDEV : error -6241: Internal build error
Validating Custom Action sequencing
Validating architecture for custom actions.
..........
.........

Thanks,
Sooraj

sooraj_er
12-18-2013, 06:28 AM
After further analysis, I found that three components with ".Net installer class" set to "Yes" is causing this error. If I set them to "No" and take a build, it works fine.

So the issue seems to be this: setting ".Net installer class" set to "Yes" is making the standalone exe to access C:\WINDOWS\Microsoft.NET\Framework64\v4.0.3031964\InstallUtilLib.dll which doesnt exist. Instead it should access C:\WINDOWS\Microsoft.NET\Framework64\v4.0.30319\InstallUtilLib.dll as I specify this path using -t argument to IsCmdBld.exe.

I am confused how to proceed further as I cant take a build with ".Net installer class" set to "No" for these components as they hold .Net exe's which should be registered during installation.

alglag
01-21-2015, 09:36 AM
Anybody every found solution for this issue? I have exactly the same problem.