PDA

View Full Version : Error 404 when trying a New Post



cornerg
12-02-2013, 09:47 AM
I typed a long description of a problem I had. It was mostly in simple letters but had a bit of punctuation. Including two exclamation marks together at one point. When I pressed the submit button I got Error 404 and the post was not published.
I then tried a simple post Test as title and test as body and that was ok, So I then went back to my original post text and started cutting out odd characters.

Finally after removing the double exclamation it worked.

The same seems also to be true of 2 question marks together. Or two periods (full stop
Curious.

DebbieL
12-02-2013, 11:19 AM
Thanks for reporting the problem. This has been fixed:
..
!!
??

DLee65
12-02-2013, 01:40 PM
I am getting the same problem Debbie. I have been trying to post a new item all morning but without success. :D. I sent a message to the web master if that makes any difference.

I can reply to an existing post all day long though.

Dan

DebbieL
12-02-2013, 01:43 PM
Sorry to hear that. Can you post a text file that contains the text? Then we can try to figure out what is being blocked, and hopefully get a fix put in place.

Thanks!

DLee65
12-03-2013, 06:17 AM
Actually It would not let me attach the post either Debbie. So it must be with how my post is formatted. I may be able to help there. For the most part the post is plain text.

The only thing is I have a 'code' segment with a snippet from a PRQ file with HTML tags within the code segment.

So without using the actual code segment and html tags, here is what I have. Perhaps you can reproduce it.

'CODE'<condition Type="32" Comparison="2" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\SQLEXPRESS\MSSQLServer\CurrentVersion" FileName="CurrentVersion" ReturnValue="11.0.3000.0"></condition>'/CODE'

'CODE'<condition Type="32" Comparison="2" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\AMAZINGCHARTS\MSSQLServer\CurrentVersion" FileName="CurrentVersion" ReturnValue="11.0.3000.0"></condition>'/CODE'

Let's see if this will post without the normal CODE tags. I wonder if HTML inside of CODE tags is bad stuff.

DLee65
12-03-2013, 06:20 AM
Here is the plain text around the code segments, just to see if that is problematic.

First, let me state that I have done my homework, and searched the same issue that is reported elsewhere. I have even commented on this same issue for others to make sure that people have changed the PRQ file condition for installing SQL Server # Express.

However, I have done this, and I have verified the syntax is identical in the operating system to the PRQ.
I have also removed the AltPrqURL reference from the PRQ file to make sure that the default PRQ file is not being downloaded from InstallShield.

So the default condition is this:
*** INSERT CODE SEGMENT HERE ***
Notice that ONLY the instance name varies in the condition. Using a comparison tool, none of the other conditions are different.
The other differences are the command line for installation and the removal of the AltPrqURL reference.

Logically, this should be working as I understand the PRQ syntax. I am asking it to check to install if the value is less than. Upon install the registry path does exist and the version does equal the value noted above.

Is there something else that I am missing here?

Thanks.

DebbieL
12-03-2013, 09:43 AM
Ah, got it. I'll report this internally and see if ASAP we can unblock this type of content (PRQ text), as well as fix the attachment problem.

DLee65
12-03-2013, 10:11 AM
I am trying to submit another new post Debbie and having problems with that too. This time I am leaving out any QUOTES, CODES, etc. and it still fails. Hopefully I can post most of my page here.
I am including the standard Microsoft Visual C++ 2005 SP1 Redistributable Package (x86) in a Suite package.
If I include the PRQ file in a basic MSI package I can successfully install the prerequisite on Windows 7 x86.
If I include the PRQ file in the Suite package the install fails.
The command line looks correct, below is information from the debuglog file.

Will launch exe: C:\Users\DLee\AppData\Local\Downloaded Installations\{8034C99E-3BC0-4E53-BC6E-02E3D8CF5378}\vcredist_x86.exe
EXE parcel command line: /q:a /c:"VCREDI~1.EXE /q:a /c:""msiexec /i vcredist.msi /qb! /l*v %tmp%\vcredist_x86_2005.log"" "
EXE parcel resolved command line: /q:a /c:"VCREDI~1.EXE /q:a /c:""msiexec /i vcredist.msi /qb! /l*v %tmp%\vcredist_x86_2005.log"" "
Launch EXE result: 0
Final result status for EXE parcel: 0
Engine: property 'ISInstallStatus' value now 'Package operation complete'
Engine: property 'ISParcelStatus' value now 'ID_STRING51
Parcel operation return status: 0
No registry indicators appear to signal a reboot is pending
Re-running parcel detection for parcel {8034C99E-3BC0-4E53-BC6E-02E3D8CF5378}, install state: 0
UI DLL: Display Error: The installation of Microsoft Visual C++ 2005 SP1 Redistributable Package (x86) appears to have failed. Do you want to continue the installation?
Transaction: parcel returned error status 80004004

It appears that it did not even attempt to execute the package.
Note that this log file shows the /qb! option. I had manually changed this test run to this value. The original value is /qn. I wanted to see if the UI even shows up as part of debugging this.

Could it be that I need to alter the quotes for the Suite installer? I had double checked this with Aaron Stebner's blog post to verify the syntax. He is usually my go-to guy for issues on redistributable syntax.
Perhaps the logging syntax is throwing it off?

DLee65
12-03-2013, 10:24 AM
Debbie,

It is a problem with the path statements it seems. I am still back on the InstallShield 2013 forum and I cut out the block of text up to

Will launch exe: C:\Users\DLee\AppData\Local\Downloaded Installations\{8034C99E-3BC0-4E53-BC6E-02E3D8CF5378}\vcredist_x86.exe

I can preview everything up until that line. Once I add this line the preview fails and I get a 404 error.
I can alter the path statement to C:\PathToFile\vcredist_x86.exe and it will still fail. So it is not something funny with curly braces either.

Hopefully that helps.