PDA

View Full Version : Main MSI installer not waiting for inner MSI to complete



ablaze117
10-25-2013, 12:50 PM
So I have read quite a bit and tried multiple settings, however I cannot figure this out for the life of me.

Basically I am running an inner installer within my msi silently using /s /v"/qn" switches. How I currently have it set up is that I drop the inner installer to the my destination folder, and then execute it during my installation.

So in the Install Exec Sequence, I have it set to "After InstallFiles". Return processing is set to Asynchronous (No wait for completion).

However, any other option other than Asyncronous (No wait for completion) fails. The installer will simply continue on and never run the inner msi unless that specific option in return processing is set.

Obviously this is not what I want. I want my main installer to wait for the completion of the inner installer before proceeding. Currently it will start the inner installer, and then my msi will install concurrently with it.

This causes problems as obviously I want to wait for the inner msi to finish before my installer does. In the end it works, and everything is deployed like it is supposed to be without conflict, but I fear this will cause problems when running this package through WDS.

jlynch11
12-27-2013, 04:23 PM
Creating nest/concurrent installations is deprecated by Microsoft. Instead perhaps consider using a chained MSI, suite project (if you have Premier) or an Installscript wrapper.

If you must create a nested installer, however, I suggest taking a look at the following kb article which contains additional steps and information: http://flexerasoftware.force.com/ka2G0000000UFLnIAO