PDA

View Full Version : Enabling Single Sign-On on IIS 7



Filip Mares
10-25-2013, 06:53 AM
Hi there,

I am trying to enable single sign-on on our AES 2013, but since the IIS is running in the Integrated Mode, I am not able to enable Forms Authentication and Windows Authentication at the same time. The documentation does not say anything about this, maybe somebody has some experience in how to work this out?

Thanks.
Filip

Evan Border
10-26-2013, 02:00 PM
I am trying to enable single sign-on on our AES 2013, but since the IIS is running in the Integrated Mode, I am not able to enable Forms Authentication and Windows Authentication at the same time. The documentation does not say anything about this, maybe somebody has some experience in how to work this out?

Despite that IIS says not to enable both, you can. I just checked my AES 2013 site and both Forms Authentication and Windows Authentication are enabled (all others are disabled) and single sign-on is working like a champ.

Filip Mares
10-28-2013, 06:50 AM
Despite that IIS says not to enable both, you can. I just checked my AES 2013 site and both Forms Authentication and Windows Authentication are enabled (all others are disabled) and single sign-on is working like a champ.

Thanks a lot, it indeed works!
I got confused, as I have started the AdminStudio, there is a login window in the beginning, to login to your AES. I have had the URL as IP Address of the server and I was getting the following error (only once I have disabled the Anonymous Authentication and enabled the Windows one):
---------------------------
AdminStudio
---------------------------
Error: 0x800A1518

If you are using a Web Portal with custom security zone settings
and your AdminStudio Enterprise Server URL is using an IP address,
change the AdminStudio Enterprise Server URL to the NetBios equivalent
then try again.
---------------------------
OK
---------------------------

But as I have changed the IP Address to a hostname, this problem have now disappeared.

Thanks a lot.
Filip