PDA

View Full Version : Initializing engine failed



Tiger12
09-16-2013, 04:53 AM
I have a problem with the installscript engine on a Windows 7 (32-Bit, Home Premium)-machine:
...
Aktion gestartet um 10:15:25: FindRelatedProducts.
Aktion beendet um 10:15:25: FindRelatedProducts. Rückgabewert 1.
MSI (c) (68:74) [10:15:25:139]: Skipping action: Check_NewerProduct (condition is false)
MSI (c) (68:74) [10:15:25:139]: Skipping action: Check_OldProduct (condition is false)
MSI (c) (68:74) [10:15:25:139]: Skipping action: Message_URInstalled (condition is false)
MSI (c) (68:74) [10:15:25:139]: Doing action: Message_NoIsScriptSetProperty
Aktion 10:15:25: Message_NoIsScriptSetProperty.
Aktion gestartet um 10:15:25: Message_NoIsScriptSetProperty.
MSI (c) (68:00) [10:15:25:144]: Invoking remote custom action. DLL: C:\Users\KLEIN&~1\AppData\Local\Temp\MSI2495.tmp, Entrypoint: f10
InstallShield 10:15:25: Running InstallScript function f10
InstallShield 10:15:25: Opening stream of file C:\Users\KLEIN&~1\AppData\Local\Temp\MSI2495.tmp
InstallShield 10:15:25: Extracting support file IsConfig.ini to C:\Users\KLEIN&~1\AppData\Local\Temp\{F388B038-4843-4E53-8F17-F08593A8563D}\IsConfig.ini
InstallShield 10:15:25: Extracted isconfig.ini to C:\Users\KLEIN&~1\AppData\Local\Temp\{F388B038-4843-4E53-8F17-F08593A8563D}\IsConfig.ini
InstallShield 10:15:25: Got '{59B48841-A44F-4CA9-B3B3-85816B1DAC87}' for TempPathGuid from isconfig.ini
InstallShield 10:15:25: Attempting to use temp path 'C:\Users\KLEIN&~1\AppData\Local\Temp\{59B48841-A44F-4CA9-B3B3-85816B1DAC87}'
InstallShield 10:15:25: Using new temp path
InstallShield 10:15:25: Cleaning up temp file C:\Users\KLEIN&~1\AppData\Local\Temp\{F388B038-4843-4E53-8F17-F08593A8563D}\IsConfig.ini
InstallShield 10:15:25: Using temp folder C:\Users\KLEIN&~1\AppData\Local\Temp\{59B48841-A44F-4CA9-B3B3-85816B1DAC87}
InstallShield 10:15:25: Installing engine...
InstallShield 10:15:25: Using product language 1031
InstallShield 10:15:25: Skipping optional support file _isuser_0x0407.dll
InstallShield 10:15:25: Setting script cmdline...
InstallShield 10:15:25: ProductCode is {11EC0CBA-33BB-4954-A4A6-3EB02899B473}
InstallShield 10:15:25: Initializing Engine
CustomAction Message_NoIsScriptSetProperty returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Aktion beendet um 10:15:31: Message_NoIsScriptSetProperty. Rückgabewert 3.
MSI (c) (68:74) [10:15:31:826]: Doing action: SetupCompleteError
Aktion 10:15:31: SetupCompleteError.
Aktion gestartet um 10:15:31: SetupCompleteError.
Aktion 10:15:31: SetupCompleteError. Dialog created
MSI (c) (68:40) [10:15:31:836]: Note: 1: 2731 2: 0

Does anyone have an idea?

Tiger12
10-11-2013, 02:47 AM
I could now solve the problem. One of the user shell folders could not be access.

With SP1 of Installshield 2013 the error no longer occurs.