PDA

View Full Version : Repackager 32/64 bit registry keys



Martin
08-13-2013, 08:42 AM
Several registry keys are lost during repackaging of a 64 bit application consisting of 32 and 64 bit files. The graphical representation of the irp file shows the 64 bit (e.g. Software\Classes\CLSID\GUID) and 32 bit (e.g. Software\Wow6432Node\Classes\CLSID\GUID) registry keys. However the resulting ism project only contains the 64 bit keys (and a single 32 bit key because its value differs from the 64 bit value) assigned to a 64 bit component.

A partial dump of the Registry table of the ism file:
Key1 0 CLSID\{73C9DFA0-750D-11E1-B0C4-0800200C9A66} FlashBroker flashutil64_11_7_700_224_activex.exe_COM
Key2 0 CLSID\{73C9DFA0-750D-11E1-B0C4-0800200C9A66} LocalizedString @C:\Windows\system32\Macromed\Flash\FlashUtil64_11_7_700_224_ActiveX.exe,-101 flashutil64_11_7_700_224_activex.exe_COM
Key3 0 CLSID\{73C9DFA0-750D-11E1-B0C4-0800200C9A66} LocalizedString @C:\Windows\SysWOW64\Macromed\Flash\FlashUtil32_11_7_700_224_ActiveX.exe,-101 flashutil64_11_7_700_224_activex.exe_COM
Key4 0 CLSID\{73C9DFA0-750D-11E1-B0C4-0800200C9A66}\Elevation Enabled #1 flashutil64_11_7_700_224_activex.exe_COM
Key5 0 CLSID\{73C9DFA0-750D-11E1-B0C4-0800200C9A66}\LocalServer32 [System64Folder]Macromed\Flash\FlashUtil64_11_7_700_224_ActiveX.exe flashutil64_11_7_700_224_activex.exe_COM
Key6 0 CLSID\{73C9DFA0-750D-11E1-B0C4-0800200C9A66}\LocalServer32 [SystemFolder]Macromed\Flash\FlashUtil32_11_7_700_224_ActiveX.exe flashutil64_11_7_700_224_activex.exe_COM
Key7 0 CLSID\{73C9DFA0-750D-11E1-B0C4-0800200C9A66}\TypeLib {FAB3E735-69C7-453B-A446-B6823C6DF1C9} flashutil64_11_7_700_224_activex.exe_COM


The only 32 bit key left in the dump above is: "Key3 0 CLSID\{73C9DFA0-750D-11E1-B0C4-0800200C9A66} LocalizedString @C:\Windows\SysWOW64\Macromed\Flash\FlashUtil32_11_7_700_224_ActiveX.exe,-101 flashutil64_11_7_700_224_activex.exe_COM"


What should I do to keep the 32 bit registry keys as well and get them assigned to the 32 bit component? 32BitTarget is set to 0 in default.ini. The rest of the options is left on their default "out of the box" value.

Thanks in advance.

Martin
08-26-2013, 07:34 AM
Nobody?

Is the question or problem description not clear?