PDA

View Full Version : Management Objects and System CLR Types for SQL Server 2012?



Christopher Jay
07-29-2013, 03:21 PM
Hello,

I just started using Installshield 2013 Professional. I am happy to see the SQL Server 2012 Express merge module and it works fine, but I also need a merge module for SQL Server Management Objects 2012 and SQL Server System CLR Types 2012. I only see the 2008 versions in Installshield 2013 Professional.

Does anyone know where I can obtain these?

Thanks a lot for your help.

hidenori
07-30-2013, 04:17 PM
I filed the work order IOA-000081241 to address the issue in a future release. For now, you can create your own prerequisites for those modules. Please refer to the Defining InstallShield Prerequisites (http://helpnet.flexerasoftware.com/installshield20helplib/installshield20helplib_CSH.htm#helplibrary/IHelpSetPrereqCustom.htm) help topic on how to create a custom prerequisite.

Hope that helps.

Christopher Jay
07-30-2013, 04:39 PM
Thanks. I'll try and figure that out.

Christopher Jay
07-30-2013, 07:50 PM
I filed the work order IOA-000081241 to address the issue in a future release. For now, you can create your own prerequisites for those modules. Please refer to the Defining InstallShield Prerequisites (http://helpnet.flexerasoftware.com/installshield20helplib/installshield20helplib_CSH.htm#helplibrary/IHelpSetPrereqCustom.htm) help topic on how to create a custom prerequisite.

Hope that helps.

In the past, have new merge modules like this been released before a new major version? i.e. will it show up in 2013 at one point, or will it wait all the way until 2014?

SimonG
09-11-2013, 06:58 AM
I filed the work order IOA-000081241 to address the issue in a future release. For now, you can create your own prerequisites for those modules. Please refer to the Defining InstallShield Prerequisites (http://helpnet.flexerasoftware.com/installshield20helplib/installshield20helplib_CSH.htm#helplibrary/IHelpSetPrereqCustom.htm) help topic on how to create a custom prerequisite.
Hope that helps.

1) Prerequisites don't work with skinned installations.
2) Prerequisites are not feature or component specific, so if only a small component or feature of the install needs the SMO this does not work well as it forces SMO to be installed even when it's not needed.

It would be very useful for us to have Merge Modules for SMO and CLR types as instead we're either going to have ask the customer to install it (and check they have in the installation by looking at the registry).