PDA

View Full Version : .NET 4CP prereq problem



jgkenned
12-04-2012, 04:38 PM
I have an InstallShield project (Basic MSI project) that has a requirement for .NET 4 CP. This IS project/install is designed for 64 bits systems like Windows 7 and Windows server 2008. The prereq check (for .net) seems to fail for Windows 2008 64 R2 but works correctly on Windows 7 64. In order words, I get the dialog box with a pending install for .NET in a Windows 7 64 environment but for Windows 2008 server 64 I do not. It blows right past it and proceeds to install my application which of course fails testing later on due to a lack of .net 4.

thanks for any help.

jgkenned
12-05-2012, 02:23 PM
I was able to figure this one out. Because Windows 2008 R2 x64 and Windows 2008 x64 are seen as different platforms by IS, I had to edit and add windows 2008 R2 x64 to the preq conditions for .NET version 4. I really did not expect this. I expected the most common platforms to be covered by the default preq's and R2 is not part of those default conditions.