PDA

View Full Version : Error when Installing via Suite



rguggisberg
10-12-2012, 02:19 PM
I am trying do a Suite installation of a new version of our product using 2012 Spring. The Suite install of the old version worked fine. I have not yet updated to SP1 as I did not want to introduce another variable. Everything seemed to go ok and the Suite build completes without errors. When I run the Suite on a clean machine it installs the first package correctly and then exits with the message
"The wizard was interrupted before your requested operations were completely performed."
It will correctly install the first package I select (whichever package I select) and then exit. So I got a log and there are errors. Where do I find out what these errors mean?
"Setup.exe Return Values and Run-Time Errors (Advanced UI and Suite/Advanced UI Projects)" in HELP is something like what I am looking for, but the errors below are not in there.

Part of the error log:
10-12-2012[02:55:46 PM]: Launch EXE result: 0
10-12-2012[02:55:46 PM]: Final result status for EXE parcel: 80070bc2
10-12-2012[02:55:46 PM]: Engine: property 'ISInstallStatus' value now 'Package operation complete'
10-12-2012[02:55:46 PM]: Engine: property 'ISParcelStatus' value now 'ID_STRING10'
10-12-2012[02:55:46 PM]: Parcel operation return status: 80070bc2
10-12-2012[02:55:46 PM]: No registry indicators appear to signal a reboot is pending
10-12-2012[02:55:46 PM]: Parcel status appears to indicate a reboot is necessary
10-12-2012[02:55:46 PM]: Engine: property 'ISDelayReboot' value now 'true'
10-12-2012[02:55:46 PM]: Re-running parcel detection for parcel {894A3A4D-EC5E-47C0-BE3E-C4F7AE68E2F9}, install state: 0

If I log a suite install from my previous version the line above is "installstate: 1", with a different parcel number of course.
Then the lines below differ as well.

10-12-2012[02:55:46 PM]: Transaction: parcel returned error status 80004004
10-12-2012[02:55:46 PM]: Transaction: finished running parcels, will roll back transaction
10-12-2012[02:55:46 PM]: End transaction result: 1
10-12-2012[02:55:46 PM]: Engine: error 80004004 while running parcel operations
10-12-2012[02:55:46 PM]: Engine: parcel operations completed, sending completed event to UI
10-12-2012[02:55:46 PM]: Engine: property 'ISInstallStatus' value now 'IDS_SUITE_INTERRUPTED'
10-12-2012[02:55:46 PM]: Engine: property 'ISParcelStatus' value now ''
10-12-2012[02:55:46 PM]: Engine: property 'ISCurrentPage' value now 'InstallationComplete'
10-12-2012[02:55:46 PM]: Engine: property 'ISCurrentPage' value now 'InstallationComplete'
10-12-2012[02:56:00 PM]: UI DLL: Shutting down
10-12-2012[02:56:00 PM]: Engine: all operations completed, final status: 80004004
10-12-2012[02:56:00 PM]: Original exit status: 0x80004004, final exit status: 0x00000642
10-12-2012[02:56:00 PM]: State manager: cleaning up state info

rguggisberg
10-15-2012, 02:17 PM
Problem was caused by the fact that I did not have the correct 'Product Version' on my Detection Condition for the Packages. Although it did install a package... it's just that the Suite would not complete successfully.

Still would be nice to know where to find error code definitions.