PDA

View Full Version : InstallShield Bizarreness



RonNYC
09-27-2012, 10:06 AM
I'm not sure which version; probably fairly old. I downloaded an app from a web site. It installed perfectly well on my laptop but when I tried to install it on my new desktop (both run Win7 64) a problem occurred. A long time ago (and on a different computer) a friend of mine wrote a program for me, which used install shield. This program has never been installed on my current computer. When I tried to install this new program, an Install Shield dialog box comes up with that old name on it and in fact does install something with that old name on it. I thought I'd delete the InstallShield folder in \windows\SysWow64\ but even running as admin I cannot.

Any suggestions, hints, whatever are greatly appreciated.

RON

skutnar
09-27-2012, 12:55 PM
First of all, it's not clear what kind of problem or issue you're having. Is there an error message or other failure?

Second of all, this forum is for those that are using InstallShield to develop installation packages, not users of applications packaged with InstallShield.

RonNYC
09-27-2012, 05:43 PM
Thanks. Do you know where I should post?

But in answer to your question, Yes, got an error. I found an old .msi file from the old application. X.msi. I deleted it and then ran the new installer and got an error:

Unable to locate application file 'x.msi'.

I would have thought that all information for the install was located in the exe file (zip), but apparently not. What is the installer looking for? Why would it try to find some .msi file on my hd?

skutnar
09-28-2012, 08:31 AM
You need to direct your questions to the author of the application, as only the author will be able to help with the particulars of their installer.