PDA

View Full Version : InstallShield crashes when adding Prerequisites in a Suite project



Thomas Hübner
09-26-2012, 02:48 AM
Hello,

since yesterday we also have Installshield 2012 Spring (Premier Edition). I installed InstallShiled in a virtual machine on Windows 7 - 32bit.

Now I tried to create a Suite project for our new release. When I add a prerequiste (e.g. .NET Framework 4.0) the whole program crashes: "InstallShield need to close."

The technical detail contains this:

Exception ACCESS_VIOLATION (0xc0000005)
at address 0x084dde1e trying to read address 0x00000000.

File : C:\Program Files\InstallShield\2012Spring\System\isdev.exe
Version : 19.0.0.185
Exception : c0000005
Address : 084dde1e
Access Type : read
Access Address : 00000000

Registers : EAX=00000000 CS=001b EIP=084dde1e EFLGS=00010202
: EBX=00000000 SS=0023 ESP=0012f3a8 EBP=75f33eae
: ECX=21c257e6 DS=0023 ESI=00000001 FS=003b
: EDX=00000000 ES=0023 EDI=06f12120 GS=0000

Stack Trace : 758b56ec 00000000 00000000 00000000
: 00000000 00000000 00000000 00000000
: 00000000 00000000 00000000 00000000
: 00000000 00000000 00000000 00000000
: 00000000 00000000 00000000 00000000
: 00000000 00000000 00000000 00000000
: 00000000 00000000 00000000 00000000
: 00000000 00000000 00000000 00000000

This crash also occurred with a brand new project. I could not found any log file and there is now entry in the windows event log.

Is there something wrong with my installation?

Thanks for your advices.
Thomas

Thomas Hübner
10-15-2012, 03:10 AM
Is there any solution how to add prerequisites (like .NET) to a Suite project?

JBeauvais
10-25-2012, 06:15 PM
I am having the same problem. This worked without issue before Spring SP1 was released! Is there a hotfix available for this?

sidetnee
10-26-2012, 07:31 AM
Just to add my voice, Me Three.
Running on Windows 8 Enterprise x64.

Either of you guys under maintenance and raised a service request?

DebbieL
10-26-2012, 11:11 AM
This is logged as issue IOB-000062084. I believe that a KB article that explains how to resolve this is in the works. In the meantime, to fix this, find the following file:

InstallShield Program Files Folder\Support\Prq2Parcel.xslt
Make a backup copy just in case you need to revert back to it.

The second line of that file is this:

<xsl:transform version='1.0' xmlns:xsl='http://www.w3.org/1999/XSL/Transform' xmlns="installshield/2012.2/bootstrap">

Change it to this:

<xsl:transform version='1.0' xmlns:xsl='http://www.w3.org/1999/XSL/Transform' xmlns="installshield/2012.4/bootstrap">

I hope that helps.

JBeauvais
10-26-2012, 11:23 AM
That fixed it. Thank you so much!

sidetnee
10-29-2012, 03:51 AM
Also confirming that making this change resolves the issue.
Thanks.

/SiD

dileep.koppu
05-27-2014, 03:59 PM
This is logged as issue IOB-000062084. I believe that a KB article that explains how to resolve this is in the works. In the meantime, to fix this, find the following file:

InstallShield Program Files Folder\Support\Prq2Parcel.xslt
Make a backup copy just in case you need to revert back to it.

The second line of that file is this:

<xsl:transform version='1.0' xmlns:xsl='http://www.w3.org/1999/XSL/Transform' xmlns="installshield/2012.2/bootstrap">

Change it to this:

<xsl:transform version='1.0' xmlns:xsl='http://www.w3.org/1999/XSL/Transform' xmlns="installshield/2012.4/bootstrap">

I hope that helps.

i am using installshield 2013, and have the same issue. but the path you specified is different.

"<xsl:transform version='1.0' xmlns:xsl='http://www.w3.org/1999/XSL/Transform' xmlns="installshield/2013/bootstrap">"

Could you suggest some resolution to me?

DebbieL
05-28-2014, 08:36 AM
I haven't heard about that specific bug being present in InstallShield 2013. Can you describe the symptoms that you are seeing? Does InstallShield crash when you add a prerequisite to a Suite/Advanced UI Project? Or are there other steps we'd need to take to reproduce the problem?

Thanks.