PDA

View Full Version : 256x256 icon not working



Llandr
09-04-2012, 08:14 AM
I have an icon for the shortcut to my application.
The icon file has four sizes 16x16, 32x32, 48x48 and 256x256.
After installation the shortcut seems to have lost the 256x256 version.
Anyone with the same problem?

DLee65
09-12-2012, 02:55 PM
Is this a MSI install? I wonder if something happens with the advertised shortcuts compared to a straight shortcut. As I recall an advertised shortcut is created by the MSI engine and points to a small stub that checks for the application resiliency prior to starting the application.

This is just educated speculation on my part however.

Llandr
09-13-2012, 01:40 AM
It is a Basic MSI project. But the shortcut is not advertised.
I have submitted this to Installshield support.

Ymgvee
10-03-2013, 05:41 AM
I'm having this problem now - our file type icons aren't being integrated properly in the executable stubs, the 256x256 image is missing.

Additional info: This only seems to happen when using loose .ico files. When refering to an icon inside an executable, it works.

Llandr
10-03-2013, 06:15 AM
I'm having this problem now - our shortcut icons aren't being integrated properly in the executable stubs, the 256x256 image is missing.

I was never able to get this to work. Flexera blamed Microsoft and Windows installer. For me it wasn't important enough to put the time in to solve this. Please put a post here if you solve it.

Ymgvee
10-04-2013, 07:00 AM
The workaround I found was to embed all icons inside the main executable and refer to those instead of the loose .ico files. Then it manages to extract the 256x256 icons correctly.

NAndre
09-01-2014, 05:20 AM
Hello, can somebody from IS tell me if it is fixed.
We use IS Premier 2014 and have the same same Problem.

Have I to install a hotfix?

Best regards
André