View Full Version : Failed to grab execution mutex. System error 258

08-07-2012, 03:49 PM
I'm getting this error when executing a chained MSI within a basic MSI project. At the moment, I only have 1 chained MSI but will need to include about a dozen of them.

I see in the log that for some reason, the chained msi executes successfully but on return I get this error which causes the chained package to rollback.

Any suggestions? I'm stumped. I'm using as a prerequisit windows installer 4.5 which should allow chaining. I'm testing on a windows 7 machine which has installer version 5 so not sure why this is happening. I've been wasting a ton of time trying to resolve this problem without a solution

08-08-2012, 10:01 AM

No suggestions?

08-09-2012, 04:58 PM
We've not run across an error like this with chained packages before. An error like this would typically have occurred if a custom action is run in the install execute sequence of another MSI package, which will cause the global installer mutex to be held by the first install and the package launched by the custom action would then fail to install with this error.

To try isolating this issue, does this happen on all machines or just some? If it happens on all machines, have you tried putting together a couple of simple MSI packages (that contain one feature, one component, one file) and see if they can be chained or if they can be included as chained packages in your main project? Based on this, the behavior should be isolated to a machine or a specific MSI package, at which point it can be focused on.

08-28-2012, 01:33 PM
I've seen that in our logs as well and concluded (perhaps falsely) that the error can be safely ignored. It's been that way through 7 releases of our product.

02-04-2013, 10:07 AM
Hi, I got the same error in a Install Shield 2011 chained msi project also.
I am trying to find the reason but until now I didn't find anything.
Did you found a most probable cause for it in the chained projects?

02-19-2013, 10:52 AM
I'm encountering the same issue. IS2012 basic msi with one chained msi. I'm hunting for a solution and if I get one I will post it.

04-08-2013, 03:42 AM

Has anyone managed to solve this?

I have 2 instalaltions sharing the same chained MSI.
One hase 6 chained MSIs and the other only 2 of them.

The parent with the 2 chained is working fine, however the one with the 6 is presenting the error 258 message for each of the MSIs.
I can see files deploying and then as the parent installation finishes, the files are removed (I understand this is the chained MSI rollback).

I've tried reboot - no use.
I've installed one of the chained MSIs manually - behaved normally.

This happens only after upgrade from IS2009 to IS2012 Spring.

The log is very similar to the logs presented previously on this thread.

Any ideas?