PDA

View Full Version : Cannot display readme file from "Setup Complete Success" dialog



LLeeGM
02-23-2012, 05:11 PM
Hi there,

We are having an issue with the "Show the readme file" option on the "Setup Complele Success" dialog.

At present we have one version of the readme.txt file for Windows 2000 platforms and a different one for all other Windows platforms. The version to be installed is correctly being set in the "Files" where the "Properties" for the two readme.txt files are set to be installed on the correct target operating systems - one only has "Windows 2000" checked, while the other has all other operating systems checked. The installation location of the readme.txt file is the same for all platforms.

The actual installation is working correctly - we can see that the correct version of the readme.txt file is being installed on the appropriate platforms and it is definitely present.

The problem comes in with the "Show the readme file" option. On all non-Windows 2000 platforms, the readme file opens up in Notepad and displays fine when one clicks the "Finish" button on the dialog. However, when the installer is run on Windows 2000, after clicking the "Finish" button, we get the message:

"Cannot find the file '\readme.txt' (or one of its components). Make sure the path and filename are correct and that all required libraries are available."

even though, as mentioned earlier, the file is actually present (looked at it in Windows Explorer, found it where it was supposed to be, opened it in Notepad and it was fine).

Any ideas on how to fix this? Or is this a known bug? :confused: (I tried this project in InstallShield Express 2011 just to see if it was a 2010 bug but it happens with the setup that I built with that version as well)

Thanks in advance for any help!