PDA

View Full Version : Migration to IA2011 Fail



amitaks2
11-20-2011, 10:36 PM
Hi All,
I tried to migrate my IA2009 project file to IA2011 and tried to build through ant, but getting following error.

-------------------------------------
[buildinstaller] Building Installer...
[buildinstaller] Build Configuration Name: Migrated_Configuration

[buildinstaller] Active Build Options: Merge module Default Optimize By Platform

[buildinstaller] InstallAnywhere temporary directory is located at:: E:\myproject_test\checkout\merge-modules\install\.buildinstaller1.
[buildinstaller] Creating build directories...
[buildinstaller] [ 2011-11-20 22:27:19 ] BUILD STARTING
[buildinstaller] Preparing to build......
[buildinstaller] Adding other errors: The uninstaller should be associated with InstallAnywhere Uninstall Component
[buildinstaller] Build failure: The uninstaller should be associated with InstallAnywhere Uninstall Component
[buildinstaller] null
[buildinstaller] Closed.
[buildinstaller] The uninstaller should be associated with InstallAnywhere Uninstall Component
[buildinstaller] Please associate the Uninstaller (Create Uninstaller Action) with the "InstallAnywhere Uninstall Component"
[buildinstaller] EXITING: 801

BUILD FAILED


It ask about to add uninstaller component . but its is aleadt there when i just open my old iap file(IA2009) to IA2011. My primary concern is to build my project with IA2011.

Can any one help me out to understand and debug this ant build error??

pv7721
11-21-2011, 01:39 AM
I think that this might be a new limitation in IA2011, whereas in older versions it was possible to build projects without an Uninstaller component, is no longer possible to do that in IA2011. I think that this was introduced in IA2010, I remember wanting to migrate to that version and I've seen a similar error.

amitaks2
11-21-2011, 04:08 AM
How did you resolved this issue?

amitaks2
11-21-2011, 04:31 AM
Following the resolution but no effect any other cause ???
http://helpnet.flexerasoftware.com/robo/projects/installanywhere2011/helplibrary/Ia_recreateuninstall.htm

pv7721
11-21-2011, 05:31 AM
Actually, I didn't, I haven't migrated.

amitaks2
11-22-2011, 10:55 PM
infatct it got resolved by above link. selecting the component in install section( which was added in component section)