View Full Version : Change Color of Suite Screens

09-27-2011, 04:29 PM
Is there a way to change the color of the Suite screens?

09-27-2011, 05:01 PM
Yes, you can do that. You'll want to edit the colors that are configured for the applicable brush styles. It makes it easy to make global changes to the look and feel.

For example, to edit the colors that are used in the footer (the area that contains navigation buttons like Next), in the Wizard Interface view, under Styles, select the Footer node, and configure its color-related settings in the right pane.

To determine which styles are used in which areas, click the Wizard Pages node and the Secondary Windows node, and look at the settings such as Header Background, Default Body Background, and Navigation Background.

You can create your own styles (right-click the Styles node and then click Add Brush Style) and then select that style in the setting that defines where you want to use that style.

I hope that helps.

09-27-2011, 06:25 PM
Thanks Debbie... I can't wait to try that tomorrow! That's exactly what I was hoping for :)

09-28-2011, 09:15 AM
Thanks Debbie,
I like it. MUCH better than DemoShield! A couple of observations:

1. I don't see a way to get rid of the title once I have one. For example, in your default screens, Install Welcome does not have a title, but the rest do. It seems that once you have a title you can't specify 'No Title'. I may want to specify 'No Title' if I use an image in the header.

2. There seems to be a bug if you do this:
- Specify a color of black for the text in the Header
- Specify a color of white for the text in the body
The first text field in the body ends up being black (the rest are white)!

Can you look into this or do you want me to create an incident under our Maintenance contract?

09-28-2011, 10:55 AM
Great. We're glad you like the new functionality.

1. Ah, I see what you mean. As a workaround, you can open your .issuite project file in a text editor, and look for something like this (where InstallationWelcome is the name of the wizard page, and TempTitle is the title that you want to omit.):

<Page Name="InstallationWelcome" Caption="TempTitle" Header.Image="" Visible="{Mode install}">

Delete the value for the Caption attribute. You'll end up with something like this:
<Page Name="InstallationWelcome" Caption="" Header.Image="" Visible="{Mode install}">

I'll create a work order for that so that we can take a look at it. (No need to open a support incident.)

2. Hmm. On which wizard page is this occurring? Select the control that has the text that is remaining black, and then see what style is selected in the Text Style setting in the right pane. My guess is that it's not the Body style. You may need to select a different style there, or perhaps change the color of the style that it is using.