PDA

View Full Version : Merge Module Holder object could not be inserted



Brandon Lowe
09-12-2011, 10:56 AM
I am trying to convert some of my 2011 installscript project to 2012 and I'm getting errors. So I tried to create a new installscript project and when I try to add a merge module/object to a feature i get an error message,
The object 'Merge Module Holder Object' could not be inserted, you may need to reinstall the object in order to use it.
Any ideas how to fix this?

joshstechnij
09-12-2011, 12:40 PM
You should be able to resolve this behavior by running the following command line from an elevated command prompt:
regsvr32.exe "C:\Program Files\InstallShield\2012\System\ismk18.dll"

(Ensure that the path used is the path InstallShield 2012 was installed to.)

This issue was caused by the COM registration for ismk18.dll being disabled in the IS 2012 installer. As a result, the Objects view in InstallScript projects is unable to add any objects to InstallScript projects.

Brandon Lowe
09-12-2011, 12:59 PM
Thanks Josh, that fixed it.