PDA

View Full Version : Trouble with Net2.0 SP2 and No Internet



xardoz
08-13-2011, 11:35 AM
We have a program that requires Microsoft 2.0 Framework SP2, if the target PC is online, all installs happily.

If the PC is off line and we install NetFx20SP2_x86.exe manually, then run our installer, all is fine.

But if the target PC is offline and we run our installer we get an error about downloading. See attachment.

We are trying to either allow the installer to run without internet or give the customer a clear message about installing NetFx20SP2_x86.exe, avoid the attach error.... :mad:

HELP!:eek:

TekkGuy
08-15-2011, 07:52 AM
If all you are looking for is to determine is .Net 2.0 SP2 is installed, warn the user is missing and bail the install, you can do that by doing the following:

1) Go to the "Requirements" section of your setup routine
2) Right click "Software Requirements" and select "Create New..."
3) Fill in the screens using my screen shots below
9270
9271
4) Click "Finish"

That should be all you need.

xardoz
08-26-2011, 05:12 PM
I had something similar, but was using the wrong value, but I still get the same error.... :eek:
Just double checked my work, same as the above reply

TekkGuy
09-08-2011, 08:35 AM
Is there a reason you just don't incorporate the DotNet Framework into your installation's Setup.exe so that an Internet Connection is not required?

xardoz
09-08-2011, 09:04 AM
That is what the first screen shot is about.

We had the .Net in our Setup, but when it runs, we get the above error message.:confused:

TekkGuy
09-08-2011, 11:42 AM
Actually, you don't. That's the problem. You told your installation project that .Net 2.0 is a prerequisite, but you never told it to "embed" the .Net Installation file into your Setup.exe. Because the file is not embedded, and you aren't supplying a source for it (AKA CD-ROM based install) then it's last resort is to attempt downloading the file from the internet, which obviously fails.

You need to change the option of the Prerequisite selection for .Net 2.0


Open the Redistributables tab (Under section #2)
Right-Click on the "Microsoft .NET Framework 2.0" option you are using
In the "InstallShield Prerequisite Properties" dialog, change the Build Location to: Extract from Setup.exe
Click OK
DONE!


This will tell InstallShield to wrap the .Net 2.0 Install Files inside your Setup.exe so that it doesn't need to download from the internet. Be warned, this will significantly increase the size of your Setup.exe.

xardoz
09-08-2011, 07:25 PM
We tried to embed it first, like your instructions show.

Then we tried .Net 2.0 is a prerequisite just so it would show the user a proper message.

Here are the Screen Shots, Thank You for your help, But it still does not work.

xardoz
09-23-2011, 12:07 AM
We really need a resolution to this, it all seems to hinge on the dotnetfx.exe file

TekkGuy
09-23-2011, 09:12 AM
Based on the pictures you supplied, you are not embedding the .Net Framework into your Setup.exe. If you were, then you won't get the "downloading" screen.
InstallShiled will only download the redistributables selected if it can't find it anywhere else.

I suggest you look into your settings regarding embedding to see if you can find a discrepancy. When you compile your Setup.exe, you should notice the size
of the executable increase significantly once the Framework is embedded into it.

You might want to check Step #6...
1) Under your deployment method, select the "Setup.exe" Tab
2) Make sure the last entry "InstallShield Prerequisites Location" is set to
"Follow Individual Selections"
- If you have changed it to any other selection here, it will override the previous selection to embed into the Setup.exe