PDA

View Full Version : installing into different directory leaves app unusable



lsramos
07-29-2011, 01:07 PM
A product installer that was originally created in early 2007 has been upgraded repeatedly, maintaining the same Upgrade code, while changing the product code for each new release. During this time, InstallShield Express was itself upgraded which means that our installer underwent a conversion process.

Our product will be installed into a default location, in Program Files, if the user elects to accept it, which most do. During testing of our most recent release candidate, which installs into a different folder by default, we get an error when we attempt to run the application after installation has completed. If, instead, we install this new version, but change the default such that we install into what had been the default directory for the previous version, the application runs without problem.

It appears that there is a memory of the original default directory that we cannot get around. If we copy files manually to the new (default) directory and register DLLs manually, avoiding InstallShield altogether, when we run the application we get the same error.

If I build a new installer from scratch such that it has a new Uninstall code, then run this installer, then attempt to run the application, the same error occurs.

Again, if for either of the two alternatives above, I install, either manually, or via the new installer, into what was the original default directory, the application runs.

We need to find a way to disengage the 'memory' of this original default directory so that the application can be run from a new directory.

Of course, there is the further complication that this error only occurs on a single desktop installation of Windows 7. The error does not occur on a laptop installation of Windows 7 nor on other OS platforms that we have tested. We are a small shop and don't have the resources to test on every conceivable platform.

Please can someone suggest where there might be a 'memory' of the original install location (Registry?) that could be causing the problem. I have searched the Registry and find only expected items.

Thanks.

vanshvedi
08-10-2011, 09:19 AM
when i try to uninstall a package which i created using install shield 2010 it give microsoft visual c++ runtime library pop up. saying that abnormal termination of program.
it is only happening in one PC that too not always.
please if someone knows about it do help....:confused: