PDA

View Full Version : IS2011 "Hotfix A" breaks InstallShield IDE



Japster24
11-04-2010, 09:11 AM
I just installed the "Hotfix A" in order to be able to use DIM files with shortcuts, and I can no longer view anything under the Installation Designer Organization folder (Setup Design, Features, Components, DIM References). I only see, "The webpage cannot be displayed". What happened???

I can't use my InstallShield 2011 projects anymore until this is fixed. Please help!

Hopefully the attached image came through showing my issue.

Mike Marino
11-08-2010, 11:27 AM
Are you running a IE 9 beta on the machine?

scottd72
05-12-2011, 10:55 AM
I am getting "The webpage cannot be displayed" errors all the time now using IS2011 IDE. It just started happening to me, i believe, after i installed a hotfix. Is there a way to fix this? I can't get much done if I can't view the pages.

Thanks.

Mike Marino
05-12-2011, 03:50 PM
Do you have a beta of IE 9 installed? If not what version of IE are you using?

scottd72
05-13-2011, 07:15 AM
I have IE8.

Mike Marino
05-13-2011, 10:49 AM
I would try to run a repair of InstallShield and see if that helps.

sjflex
05-17-2011, 03:24 PM
Hello, I am having the same problem with InstallShield 2010. Repair install did not fix it. I have IE9 (full version) but I don't use that browser. I had it installed before the problem occurred.

Mike Marino
05-17-2011, 05:03 PM
Try this...

Get regtypelib.exe from...

http://kb.flexerasoftware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=Q109148&sliceId=1&docTypeID=DT_ERRDOC_1_1&dialogID=109573353&stateId=0 0 109571232

Then register

C:\Program Files (x86)\Common Files\InstallShield\Shared\ISWrkSpaceMgr.tlb
and
C:\Program Files (x86)\Common Files\InstallShield\Shared\Ismauto.tlb

And see if that helps.

(Note "C:\Program Files (x86)" will be "C:\Program Files" on a 32 bit machine)

If not, look in the folder

C:\Program Files (x86)\InstallShield\2011\System

and see if there is a file called iside.log. If there is please attach it to a post (or email it to me at mmarino@flexerasoftware.com)

Sairen
07-19-2011, 09:14 AM
Can anyone confirm whether this worked? I recently applied Hotfix A to IS2011 and I'm having the same problem. I am VERY displeased.

scottd72
07-19-2011, 09:20 AM
I took Mike Marino's advice and repaired Installshield. I haven't seen this issue since.

Sairen
07-19-2011, 10:05 AM
I tried repairing the product "InstallShield 2011 with Hotfix A" and it did not fix the issue.

I downloaded Regtypelib.exe and registered both TLB files, and that did not fix the issue either. I also did not see an iside file in the System folder (there was one a level up, but it was from 2 weeks ago).

I have attached two log files - one from the initial installation of the hotfix and one from the repair. On both there was a single error dialog about one of the tmp files in config.msi being missing. On both, the option to "Ignore" was available, and installation continued without any other visible errors.