PDA

View Full Version : Never enters maintenance mode



ktinstalls
10-28-2010, 01:37 PM
Maybe I don't understand, but if I run Build/Build Cd-ROM, then Build/Run CD-ROM then immediately run Build/CD-ROM again, shouldn't I enter maintenance mode? I thought maybe I had something set incorrectly in my Basic MSI project, but I create a new Basic MSI project with all defaults and it still doesn't recognize that the product is already installed.

This is the log where it doesn't set Installed to true:

MSI (c) (94:C4) [12:17:29:679]: APPCOMPAT: Compatibility mode property overrides found.
MSI (c) (94:C4) [12:17:29:679]: APPCOMPAT: looking for appcompat database entry with ProductCode '{8679B120-65CF-4E29-9BF5-37BAF5889E10}'.
MSI (c) (94:C4) [12:17:29:679]: APPCOMPAT: no matching ProductCode found in database.
MSI (c) (94:C4) [12:17:29:679]: MSCOREE not loaded loading copy from system32
MSI (c) (94:C4) [12:17:29:695]: Machine policy value 'TransformsSecure' is 0
MSI (c) (94:C4) [12:17:29:695]: User policy value 'TransformsAtSource' is 0
MSI (c) (94:C4) [12:17:29:695]: Machine policy value 'DisablePatch' is 0
MSI (c) (94:C4) [12:17:29:695]: Machine policy value 'AllowLockdownPatch' is 0
MSI (c) (94:C4) [12:17:29:695]: Machine policy value 'DisableLUAPatching' is 0
MSI (c) (94:C4) [12:17:29:695]: Machine policy value 'DisableFlyWeightPatching' is 0
MSI (c) (94:C4) [12:17:29:695]: APPCOMPAT: looking for appcompat database entry with ProductCode '{8679B120-65CF-4E29-9BF5-37BAF5889E10}'.
MSI (c) (94:C4) [12:17:29:695]: APPCOMPAT: no matching ProductCode found in database.
MSI (c) (94:C4) [12:17:29:695]: Transforms are not secure.
MSI (c) (94:C4) [12:17:29:695]: PROPERTY CHANGE: Adding MsiLogFileLocation property. Its value is 'C:\Users\ktate\AppData\Local\Temp\MSIc9306.LOG'.
MSI (c) (94:C4) [12:17:29:695]: Command Line: SETUPEXEDIR=C:\InstallShield 2011 Projects\My Project Name-1\PROJECT_ASSISTANT\CDROM_IMAGE\DiskImages\Disk1 SETUPEXENAME=setup.exe CURRENTDIRECTORY=C:\InstallShield 2011 Projects\My Project Name-1\PROJECT_ASSISTANT\CDROM_IMAGE\DiskImages\Disk1 CLIENTUILEVEL=0 CLIENTPROCESSID=148
MSI (c) (94:C4) [12:17:29:695]: PROPERTY CHANGE: Adding PackageCode property. Its value is '{229718F9-1EF4-422B-9927-97DBCB2BCAEC}'.
MSI (c) (94:C4) [12:17:29:695]: Product Code passed to Engine.Initialize: ''
MSI (c) (94:C4) [12:17:29:695]: Product Code from property table before transforms: '{8679B120-65CF-4E29-9BF5-37BAF5889E10}'
MSI (c) (94:C4) [12:17:29:695]: Product Code from property table after transforms: '{8679B120-65CF-4E29-9BF5-37BAF5889E10}'
MSI (c) (94:C4) [12:17:29:695]: Product not registered: beginning first-time install
MSI (c) (94:C4) [12:17:29:695]: PROPERTY CHANGE: Adding ProductState property. Its value is '-1'.

Thanks for any enlightenment!

Alpesh
10-30-2010, 07:49 PM
Hi,

Check the Tools -> Options -> Preferences menu, and uncheck the checkbox for 'Uninstall before installing' if it is checked.

Thanks!