PDA

View Full Version : .NetFramework 4.0 is not getting installed with MSI setup after adding into prerequis



repal.rahul
10-27-2010, 12:51 AM
I am facing following issue related to framework 4.0.

Issue: - .NetFramework 4.0 is not getting installed with MSI setup after adding as a prerequisite (in redistributables).

We have migrated project from Install shield 12 to install shield 2011 Premium Edition.
Here as per the requirement we need .NetFramework 4, so we have added that in Prerequisites & created Testsetup.msi setup.

After doing this we are expecting .NetFramework 4.0 should be installed with Testsetup.msi installation, but that is not getting installed.
Why this .NetFramework 4.0 ( Added as Prerequisites in redistributables) is not getting installed with MSI setup? Do i need to do any changes in setup command to work prerequisites correctly?

Alpesh
10-27-2010, 06:28 PM
Hi,

To install a prerequisite, you need to create a setup.exe. You cannot install a prerequisite just by running a msi file.