PDA

View Full Version : How to update "MS Visual C++ 2008 Redistributable"?



seaktf
10-20-2010, 12:39 PM
Hello,

I've found that "Microsoft Visual C++ 2008 SP1 Redistributable (x86)" prerequisite supplied in InstallShield 2011 Premier is version 9.0.30729.17.

However, the latest version is 9.0.30729.4148.

How to update this prerequisite? Even though both redistributable installers are vcredist_x86.exe, I don't think I could just put the latest vcredist_x86.exe to replace the old one which is somewhere in a subfolder of IS2011 folder. Or is it that simple?

TIA

seaktf
10-22-2010, 12:07 PM
I've just tried replacing the original vcredist_x86.exe with the new one in the "SetupPrerequisites" subfolder.

The pre-req is installed when there's no VC++ 2008 SP1 dist. installed previously. However, if the 9.0.30729.17 is already installed, 9.0.30729.4148 won't install! Maybe a matter of GUID!?