PDA

View Full Version : msbuild InstallShield task and setup.inx



jdavidi
10-19-2010, 03:56 PM
Greetings,

I am piecing together an msbuild file to build my installer (for eventual use by TFS & TeamBuild), and for the most part everything is working, with the exception of the InstallScript compile. I receive one error during the build:

ISDEV : error -7132: An error occurred streaming ISSetup.dll support file N:\TFS\Infrastructure\Installations\InstallerProjects\CostGuard\Script Files\Setup.inx

When I build via IsCmdBld.exe, everything is fine, and I can see in the build output that one of the first steps the build does is compile setup.inx, and then moves on to build the MSI tables.

When I build from msbuild, even at the diagnostic logging level, I see no evidence of the setup.rul (or other .rul file) compiles--immediately the MSI tables start building.

I'm uncertain as to if the Build="Compile" parameter of the InstallShield task is meant to compile the rul files, but when run it completes quickly with 0 errors & 0 warnings, yet there is no setup.inx.

I tried compiling setup.inx via the GUI and putting it in the scripts folder,but as soon as the InstallShield task begins, it gets deleted, presumably due to the Clean target.

So my questions:
Should the msbuild InstallShield task compile setup.inx, and assuming so, what is the trick to doing so?

Thanks much!

--jdavidi

jdavidi
11-03-2010, 01:11 PM
After weeks of headbanging and trying to determine why IsCmdBld.exe would work but an msbuild InstallShield task wouldn't, a bunch of diffing revealed that I had a path typo in my ScriptFiles path variable ItemGroup (that pointed at my rul files). Apparently Compile.exe gets skipped if no rul files are found at the expected locations (as opposed to erroring out). Just wanted to post should anyone happen to run into it.

--jdavidi