PDA

View Full Version : Error 150 : Incompatible version of cab file



gknierim
10-13-2010, 12:18 PM
We are upgrading an InstallScript 2009 Project to 2011. When we go to build we get this error. There are no Release folders to remove as others have previously suggested (years ago). Does anyone know how to fix this?

Thanks,
Greg

Update: We created a new InstallScript MSI project in 2011, brought over the script files and support files, and it compiles with no error. Has anyone converted an XML InstallScript 2009 project to 2011 as is and got it to compile?

joshstechnij
10-14-2010, 12:00 PM
Note that an InstallScript MSI project does not build the same output (data1.hdr, data1.cab) that InstallScript projects build.

If you create a new release in the migrated project and build the new release, does this error still occur?

gknierim
10-15-2010, 09:46 PM
We created a new release and still get the same error.

We are converting the project over to a MSI project since all the others are.

joshstechnij
10-18-2010, 11:08 AM
Error 150 can only occur for pure InstallScript projects. Can you clarify which project is seeing this issue? Does this occur for any project you try to build? What operating system is the InstallShield build process running on?

gknierim
10-18-2010, 12:04 PM
This only happened to the one InstallScript project we have. Oddly enough, we went back later and tried to rebuild it again and we didn't get the error again.

We are building this project using InstallShield 2011 Professional on Windows Server 2008 R2. The project is for one of our prerequisite checking tools that just basically uses the InstallScript to check and see if the system meets certain requirements before installing our software. It doesn't install anything on the system, just simply checks the system.

joshstechnij
10-19-2010, 12:03 PM
Typically this error will only occur if something is preventing the data1.hdr from being opened during the build process. On certain versions of Windows (older than Vista), there are some reasons that can cause this. In most circumstances though, there should be no issue in opening data1.hdr. If this issue occurs again, you may try shutting down any processes on the machine that can affect file I/O, such as anti-virus products. This may help to isolate the cause of the behavior.