PDA

View Full Version : iswiscanners.dll not found et. al.



TangoeDev
09-27-2010, 07:35 AM
I have had nothing but trouble using 2011 in VS 2010. Builds suddenly stop working. I am no longer able to add the output files to my project without crashing the entire solution (which only includes the website and installshield projects). This worked for a couple of weeks. I make a change in a dialog and the IDE closes it. Builds without changing anything randomly fail and crash VS. The scripts compile fine. It is an Installscript msi project.

Now, when I try to Start without debugging I get the error "Unable to start debugging File not found: iswiscanners.dll." Needless to say, it does exist. It is properly referenced in the registry. And it was able to find it for the first 3 weeks. I recreated the project. I reinstalled InstallShield. I restarted my machine. Nothing works. HELP!!!

I am now unable to use installshield because I can't run the app (debug or not) on my machine. I have to get this done. HELP!!!

TangoeDev
12-01-2010, 02:01 PM
I posted the above 2 months ago. No solution has been offered. Since then, the debugger sometimes works, and other times it doesn't, often with no code changes. Now once again I am getting the same message as above. Other people have the same issue, but nobody posts an answer. Just today the build crashed vs2010. When I got back from a meeting it built with no code changes. I did the hotfix and it did not help. I rebooted. Still doesn't work.

This is the buggiest and most poorly documented commercial application I have ever had the misfortune to use. I can't understand why it is the most widely used installer. I can't find a book written after 2007. I make a change on a form and the form closes. Intellisense only works sometimes. It recognizes some variables and functions, others not so much.

Can someone please help?

CodeGuru
12-02-2010, 12:39 AM
The software does seem to have its issues, and you won't receive any help from this forum.

Installshield support reps are however available via the phone and helpful that way. We have opened up tickets with them and spoken to the rep a few times.

Give them a call, or submit a support issue online. I have created so many bugs/issues threads in this section and a total of 0 have been resolved here. :(