PDA

View Full Version : Redistributables Nightmare



sirhaden
09-22-2010, 12:47 PM
We are attempting to set up a DirectX9 redistributable as part of our installation. When we select DirectX from the list of distributables, a dialog pops up stating “The Redistributable you have selected is either not installed on this computer, or there is a new version available from Flexera Software. Would you like to download the redistributable now?”. After selecting yes to download the redistributable, a dialog pops up stating “The download failed; make sure you are running as Administrator. Would you like to try again?”. We are running as administrator and our firewall did not block the download.

Continuing the process, we separately downloaded and installed both InstallShield 2011 MSI Objects and InstallShield 2011 InstallScript Objects. Upon restarting IS 2011, and attempting to add the DirectX redistributable we get the same original error dialog, “The Redistributable you have selected is either not installed…”.

Installation of DirectX was not an issue with previous versions of InstallShield, excluding IS 2010. This should be a trivial process that does not take hours of wasted time to end up without resolution. I firmly believe the InstallShield product should be shipped with all of the modules needed to support the list of presented redistributables.

Please provide a solution or workaround that allows us to continue with our application deployment.

DebbieL
09-22-2010, 02:41 PM
Are you using InstallShield from within Visual Studio? If so, you probably encountered the Administrator error because Visual Studio was not launched with administrative privileges. This is discussed in the following help topic:
Launching InstallShield with vs. Without Administrative Privileges (http://helpnet.flexerasoftware.com/Robo/BIN/Robo.dll?tpc=/robo/projects/installshield17helplib/launchingIS.htm)

Which project type are you using? If you are using a Basic MSI or InstallScript MSI project, you should see an ISDX9.msm file in a location such as this:
C:\Program Files\InstallShield\2011\Objects
That folder should also contain a subfolder called DirectX9.

Do you see that file and folder on your system in that location?

sirhaden
09-23-2010, 07:36 AM
After a brief attempt to use IS2010 from within Visual Studio 2010, the decision was made to use the standalone IS application. The merge modules problem is not due to lack of admin priviledges.

The project is a Basic MSI. InstallShield is installed at "C:\program files\InstallShiled". Within that folder and subfolders now lie the following DirectX components:

.\2011\Objects\DirectX9\Redist\DirectX9c

December 2005 DirectX files
No ISDX9.msm file

.\2011\ObjectsPro\DirectX 9.0 Object\Data

Unpacked DX9 redistributable
Contains DirectX9 versions from April 2005 to December 2006
No ISDX9.msm file

.\2011\Objects

ISDX9.msm file
Other *.msm files


There is only a single ISDX9.msm file within the IS directory tree at the location sited above. As far as other *.msm files, there appear to be folder containing numerous files: ".\2011\Objects" and ".\2011\Modules\i386".

When I manually use Browse for Merge Module and select the ISDX9.msm file, a dialog pops up stating it will append the path to the Merge Module Search path and then after dismissing it another dialog pops up stating “The Redistributable you have selected is either not installed on this computer, or there is a new version available from Flexera Software. Would you like to download the redistributable now?”.

So I am unable to manually download and install the DirectX9 redistributables nor am I able to download them from within the IS application...

BTW, I did a forum search on DirectX and found 73 threads (many regarding similiar issues) going back as far as July 2006. Is this ever going to be fixed?

DebbieL
09-23-2010, 08:12 AM
The path that lists the ObjectsPro is from the InstallShield 2011 InstallScript Objects download; this is for InstallScript projects only. The other two directories that you mentioned are for Basic MSI projects.

What paths are listed on the Tools > Options > Merge Modules tab? I think by default, the Merge Module Locations (Current User) box shows something like this:
C:\InstallShield 2011 Projects\MergeModules,C:\Program Files\InstallShield\2011\Modules\i386,C:\Program Files\InstallShield\2011\Objects,C:\Program Files\InstallShield\2011\Modules\i386\Japanese,C:\Program Files\InstallShield\2011\Modules\i386\German,C:\Program Files\Common Files\Merge Modules

Do you see the C:\Program Files\InstallShield\2011\Objects path in either box on that tab?

sirhaden
09-23-2010, 10:48 AM
The Merge Module Locations are:

Current User

C:\InstallShield 2011 Projects\MergeModules,C:\Program Files\InstallShield\2011\Modules\i386,C:\Program Files\InstallShield\2011\Objects,C:\Program Files\InstallShield\2011\Modules\i386\Japanese,C:\Program Files\InstallShield\2011\Modules\i386\German,C:\Program Files\Common Files\Merge Modules,c:\program files\installshield\2011\objects,c:\program files\installshield\2011\objects,c:\program files\installshield\2011\objects


All Users

C:\Program Files\InstallShield\2011\Modules\i386,C:\Program Files\InstallShield\2011\Objects,

DebbieL
09-23-2010, 11:55 AM
It appears that the InstallShield MSI Object installation is missing some of the DirectX Object files. We're working on resolving that issue. We'll update this thread when that is available.

In the meantime, though, the workaround is to download the DirectX redistributable from within the Redistributables view by right-clicking it and then clicking Download Selected Item. That should download all of the required files. I'm not sure why it is not working for you, since we haven't been able to reproduce the issue that you're seeing. What operating system are you using? How are you launching InstallShield? (Are you double-clicking the shortcut that gets automatically installed? Or some other way?)

DebbieL
09-23-2010, 12:07 PM
Also, do you use any kind of a proxy server for your Internet connection?

sirhaden
09-24-2010, 06:59 AM
I am an admin on my XP system and the same behaviour is exhibited whether I double click the IS shortcut or select "run as admin".

We do not use a proxy server so I'm not sure why downloads do not work from within IS. Other applications, such as Visual Studio, do not have any problems accessing the internet for RSS feeds, help, etc...

DebbieL
09-27-2010, 08:42 AM
Hmm. I'm not really sure what could be causing the issue. Perhaps antivirus software is somehow blocking the downloads, and InstallShield interprets that as an admin privilege problem. You may want to use Process Monitor (http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx) and see if that gives you any sort of information.

lydia.franck
06-21-2011, 08:53 AM
I am having the same problem: when trying to download a redistributable IS says I have no admin privileges - but I do have.

Is there a solution?

DebbieL
06-21-2011, 10:09 AM
What version of Windows is on your machine?

How are you launching InstallShield? (Are you using the shortcut on the Start Menu? Are you launching it from within Visual Studio?)

lydia.franck
06-22-2011, 04:22 AM
DebbieL, thanks for your reply. It was a connection problem. Now it works (on Vista, launching InstallShield via the Start Menu).

DebbieL
06-22-2011, 07:51 AM
Great. I'm glad it's working now. If you encounter problems again, you can download entire sets of them from here:
http://www.flexerasoftware.com/products/installshield/files-utilities.htm

lydia.franck
06-22-2011, 10:02 AM
Thanks for the link.
Though I am not going to download entire sets of problems ... ;-) just kidding.

It would be nice to have the the error message enhanced by the hint that connection should be checked.

DebbieL
06-22-2011, 03:37 PM
Ah, yes. We'll expand that error description. Thanks for the feedback!

Tim Mayert
08-23-2011, 10:48 AM
Well I would like to kick in here as well.

I am also running into this situation and running Win 7(64) as Admin.

I am running 2011 and I just installed the newly released 2012 and I get the same thing on both.

I was looking into the Microsoft Office 2007 PIA.prq and Microsoft Office 2010 PIA.prq (New prerequisite) and I could not download either of them. Oh and one thing I noticed when it tried to download it it was attempting to go into a misspelt Microsoft folder:
C:\Program Files (x86)\InstallShield\2012\SetupPrerequisites\Microsoft Ofiice 2010 PIA\o2010pia.msi

They have Ofiice instead of Office. So can someone in IS fix that.
http://saturn.installshield.com/is/prerequisites/microsoft office 2010 pia.prq

Some do down load and other do not. So I do not think it is a Proxy issue.

SherylSikora
08-23-2011, 11:14 AM
Tim,
The Office PIA prerqs are a bit of an oddball among the rest of the prereqs. There is actually some extra steps that you need to take to get those to work on your system. You cannot download the necessary files through the Redistributables view. To use this prerequisite, download the PIARedist.exe file from Microsoft's Web site and run it to extract the o2010pia.msi file. You can then place that .msi file into the SetupPrerequisites folder:
C:\Program Files (x86)\InstallShield\2012\SetupPrerequisites\Microsoft Ofiice 2010 PIA\o2010pia.msi
This information is detailed in the prereq itself and you should be able to view the instructions in the Redistributables view.

Sorry about the misspelling in the path, that was a mistake but it does not affect the functionality of the .prq file.

Tim Mayert
08-23-2011, 11:57 AM
Okay I have done that and placed the files in the corrected name and changed the path in the prereq file. Once done the Location no longer states needs downloading...

I do have a couple questions about the Microsoft Office 2007/2010 PIA prereqs though.

I have both attached to my install and in doing testing these prereq do not get triggered to be installed because of the conditions on these prereq.

For the 2007 PIA one of the conditions is to run if this key exists:
HKEY_LOCAL_MACHINE\Software\Microsoft\VSTO Runtime Setup\v9.0.21022

For 2010 there is a Microsoft VSTO 2010 Runtime prereq, but for 2007 there is not and therefore the prereq did not install because that registry key was not there. What creates that registry key? is it VSTO 3.0 and if so then where do I get a prerequisite for it?

As for 2010 PIA I have the Microsoft VSTO 2010 Runtime prereq run first, in which case it does, but then the 2010 PIA does not. Now the conditions on this looks like it should not install if it has already been install and that Office 2010 is not install??? So my question here is: Does installing Office 2010 preinstall this PIA and therefore it does not need to be installed or is there something wrong with the prereq conditions?

Thanks,