PDA

View Full Version : serveractutil error



Cummins_Tool
09-08-2010, 04:10 PM
Hello,

I was trying to fulfill an entitlement using serveractutil and encountered this error.

ERROR: Activation library initialization failed

These are the files in the directory along with serveractutil

FnpCommsSoap.dll
serveractutil_libFNP.dll

and this was the command

serveractutil -served -entitlementID 1234 -activatable 1 -comm soap -comServer fnoserver.com

My intent was to grab an entitlement from FNO to the host machine trusted storage.

I have run installanchorservice.exe with my publisher and product name.

Host PC is running windows 7 OS.

Can you please help us with this issue?

Thanks.

RobertDickau
09-08-2010, 05:48 PM
Does any other serveractutil usage (serveractutil -view, for example) work?

In the serveractutil sample, that message appears if flxActCommonLibraryInit fails. The default implementation just tests for an error condition; perhaps debug or modify the code to capture the specific return code? The C/C++ function reference (fnp_FuncRef-c.pdf) lists the specific return codes and reasons they occur.

(And probably irrelevant, but "-comServer" wants to be "-commServer", and the endpoint would typically be something like http://fno-server.com:8888/flexnet/services/ActivationService.)

Cummins_Tool
09-08-2010, 06:48 PM
No, when I ran serveractutil -view it gave me the same error message.

Unfortunately, I have the executable generated by another team within the company.

Is the error message indicative that serveractutil_libFNP.dll was not loaded successfully? or the activation library referenced in the error message different.

RobertDickau
09-08-2010, 07:40 PM
Correct, it usually means there's an issue with the _libFNP library (can't be found, wasn't generated from the same preptool run as the executable, and so forth).

Sometimes it refers to the FlexNet Licensing service (see the table of flxActCommonLibraryInit return codes), but you mention that you've run installanchorservice.exe...

cummins
09-10-2010, 03:16 PM
I work with the author of this thread and have gotten past this error. It appears that there was some source control issue with the built .exe or .dll.

However, now there is another error that is encountered:
Generating transfer request using:
Entitlement ID = 1234
Expiration = 31-dec-2020
Activatable Count = 1
Activatable Overdraft Count = 0
Concurrent Count = 0
Concurrent Overdraft Count = 0
Hybrid Count = 0
Hybrid Overdraft Count = 0
Repair Count = 0
ERROR: flxActSvrActivationSend - (0,42041,0)

Using the command:
serveractutil -served -entitlementID 1234 -activatable 1 -commServer http://fno-server.com:8888/flexnet/services/ActivationService

I haven't been able to find error code 42041 anywhere in the knowledge base. Any ideas?

RobertDickau
09-10-2010, 04:03 PM
Hmmm... Does it make a difference if you add -comm soap to the command line? If you look in FNO's Administer Operations view for the trusted activation request/response records, did the message make it to FNO?

P.S. Of course you'd replace fno-server.com:8888 with the actual server host name (or IP) and port number FNO is running on.

cummins
09-15-2010, 11:22 AM
Thanks, the -comm soap switch worked. serverapputil is definitely communicating with FNO now.

Now I have to figure out why we don't have a built version with our publisherId...FNO is complaining about publisherId=256 is not supported (pretty sure that was the demo publisherId).