PDA

View Full Version : ERROR after installing InstallShield Pro 2011, a build shows ISDEV: error ICE27.



bryantlk
08-19-2010, 06:50 PM
After installing InstallShield Pro 2011, a build shows ISDEV: error ICE27.

ERROR

"ISDEV: error ICE27: Unknown action: 'MsiConfigureServices' of InstallExecuteSequence table.
Not a standard action and not found in CustomAction or Dialog tables"


Environment:

Windows 7 Enterprise x64 with standard MSI 5.0+

'MsiConfigureServices' is located after 'InstallServices' and before 'StartServices',
which is correct according to documenation.

This error will show with full validation turned on.
It seems that the requirement is to run the MSI 5.0 or >, and that is how it is on my machine.

Am I getting this error because my app can be deployed to XP as well as Vista, Win7; with some platforms not running MSI 5.0~?

If I turn off full validation this can go away, but I need to get the logo from msft.

Thanks.

DebbieL
08-20-2010, 08:25 AM
I think that you are getting this error because Microsoft has not updated ICE27 to recognize that MsiConfigureServices is a standard action, new as Windows Installer 5. There are a few pages on MSDN (mostly comments from users) who have pointed this out. I'm not sure, but I would think that you should be able to ignore this validation error for this particular table.

Vijeshollithodi
11-05-2010, 02:19 PM
You might be getting this error because you put some windows logo validations. Unchek those validation from - Tools\Options\Validation and try again.