PDA

View Full Version : Downloading Residstibutables



Googoohead
08-19-2010, 11:40 AM
This is probably something really stupid that I'm not doing, but...

When I attempt to download a redistributable, I get the "download failed; make sure you are running as Administrator".

I tried changing the shortcut to "Run as Administrator" and tried running the ISDEV.EXE directly with "Run as Administrator".

What am I missing?

Thanks in advance!!!

DebbieL
08-19-2010, 02:58 PM
What operating system are you using?

Can you check the permissions on the folders to which InstallShield is trying to download the redistributables? I believe that the default locations are places like these:
C:\Program Files\InstallShield\2011\SetupPrerequisites
C:\Program Files\InstallShield\2011\Modules
C:\Program Files\InstallShield\2011\Objects
Make sure that you have permission to write to those locations.

Googoohead
08-19-2010, 03:08 PM
I'm using Windows 7

DebbieL
08-19-2010, 03:36 PM
Hmm. I have not been able to reproduce that on my Windows 7 machine. Which redistributable are you trying to download? If you go to Tools > Options > Prerequisites tab, is the All Users field disabled or enabled?

DebbieL
08-19-2010, 04:24 PM
As a workaround, you might want to try downloading the appropriate installation from the following page, and running it on your machine. That should also install the redistributable files on your machine.
http://www.flexerasoftware.com/products/installshield/files-utilities.htm

Googoohead
08-20-2010, 09:19 AM
I was trying to download the Crystal Reports Basic prerequisite. I realized that because it's trying to drop it into the Microsoft SDK's folder, the permissions there would have to be changed.

I would be nice if InstallShield provided a more intuitive message or allow me to put it into a different folder.

Thanks for your help.

DebbieL
08-20-2010, 12:45 PM
You can change the location if you want:

In the Redistributables view, right-click the Crystal Reports prerequisite and then click Edit Prerequisite. The InstallShield Prerequisite Editor opens.
On the Files to Include tab, select the file whose path you want to change, and then click the Modify button.
Specify the new path where you want to download and store the .msi file for Crystal Reports.

Once you have changed that location, you can download the prerequisite the usual way.

onur.tacettin
10-21-2010, 01:41 AM
I had the same error. I am not sure if both our sources of the problem is same or not, therefore I can't guarantee that this solution will help you, but it did work for me.

I have an anti-virus software which is quite extensive and sometimes annoying. I disabled the anti-hacker module and it worked for me. The anti virus somehow detected that process as a passive operation and not directly from the user.Hope this helps.

bobmcm461
11-09-2010, 10:58 AM
I'm running into the same problem trying to download the Crystal Basic runtime. I believe the download problem has nothing to do with where the files are being stored. (I am an administrator for my computer, and have full access to the directory in question.) In looking at the Prerequisite file, I notice that the URL to download the files from is blank. Since these files are installed when Visual Studio is installed, Installshield is assuming that the files will be there, and not giving you a way to download them. I found the files on a computer with Visual Studio installed, and copied them to the Installshield box, and the prereq shows locally installed.