PDA

View Full Version : VC++ 2005 Runtime is not installed



AlexFr
08-10-2010, 09:26 AM
I am testing InstallShield Express 2010 evaluation. Test setup package contains single executable file build in VC++ 2005 SP1, MFC. After executing the command Dependencies - Perform Dynamic Scanning, the following merge modules are selected:
Visual C++ 8.0 MFC.Policy (x86) WinSXS MSM
Visual C++ 8.0 MFCLOC.Policy (x86) WinSXS MSM
Visual C++ 8.0 CRT (x86) WinSXS MSM
Microsoft C Runtime Library 6.0

When I install this package on clean XP machine, and run the program, it shows this message: The application has failed to start because the application configuration is incorrect.
Installing vcredist_x86.exe in the target computer solves the problem. What is wrong in the installation package?

MichaelU
08-10-2010, 10:56 AM
It's unclear from the details you've shared whether your build machine has found and used the SP1 versions of the merge modules. Because of the behavior you describe, I would suspect it has not. You might try moving or renaming the merge modules it found and repairing Visual Studio, or copying the SP1 modules from another machine.

AlexFr
08-11-2010, 06:18 AM
I solved the problem by manually selecting required .msm files from C:\Program Files\Common Files\Merge Modules. It looks like InstallShield-supplied merge modules don't work in my case, I have no idea why.