PDA

View Full Version : Error -6247, Windows 7, 64-bit, InstallShield 2010 Express, no .NET Redistributables



aymanfadel
07-01-2010, 04:41 PM
ISEXP : error -6247: The .NET Framework redistributable C:\Program Files (x86)\InstallShield\2010\Redist\0409\i386\dotnetredist.exe is not found on the system. Please install the .NET Framework and rebuild.. To download more .NET redistributables, go to the Tools menu and select the "Redistributable Downloader" and/or copy the files to your standalone build installation.

What's puzzling me is that my InstallShield Redistributable Downloader shows a Last Updated 10/14/2008. The highest version number for .NET Framework is 2.0, even though I just paid for my upgrade to InstallShield 2010. My release notes (from the Help Menu):

InstallShield 2010 Express Edition (updated to include SP1, released on October 6, 2009)

About InstallShield: InstallShield 2010 - Express Edition, Version 16, Service Pack 1 with Hotfix 5241-0. Product is licensed.

Since I could not seem to get a recent version of .NET Framework redistributable, I removed it from my requirements. That did not help either.

You can download the log file from scribd.com (http://www.scribd.com/full/33795002?access_key=key-256xozykdavxb3yg353f).

You can download the InstallShield 2010 Express project (http://www.box.net/shared/b66sz3okrt).

The executable file was created with Visual Studio .NET 2008. In the project, I explicitly make the application 32-bit. The entire project is available for download (http://www.box.net/shared/5tne48thv0). It is a form which has a button which reads the value from the registry key created in the installation from the INSTALLDIR variable. I've been having problems reading registry keys on HKEY_LOCAL_MACHINE in my Visual Basic code when it got moved from XP 32-bit to Windows 7 64-bit, so I wanted to create the InstallShield Project and the DisplayInstallFolder program to make sure I can read the registry key I need. Unfortunately, I can't even get this simple InstallShield Express 2010 project to work.

DebbieL
07-06-2010, 08:22 AM
Which version of the .NET Framework do you need? The latest versions of the .NET Framework are available as InstallShield prerequisites in the Redistributables view, not as options in the Releases view. The following help topic has some more details:
Adding .NET Framework Redistributables to Projects (http://helpnet.flexerasoftware.com/Robo/BIN/Robo.dll?tpc=/robo/projects/isxhelp16/NetRedistAdd.htm)

I hope that helps.