PDA

View Full Version : LMGRD 'Exiting due to signal 15'.



hhegde
06-04-2010, 06:52 AM
Hi,
I am facing a problem of lmgrd ahutting down automatically due to 'signal 15'. Here's the log:
*****************
21:07:21 (lmgrd) SHUTDOWN request from xxxx at node xxxx
21:07:21 (lmgrd) lmgrd will now shut down all the vendor daemons

21:07:21 (lmgrd) Shutting down SW_D pid=1808 because of signal 15
21:07:21 (SW_D) Shut down FLEXnet SW_D license server system on machine xxxx
Shutdown requested from SYSTEM@xxxxx IP=xxxxx
*****************
the xxxx text above is machine names/user names.

The Flexnet version is v11.6.1.0 build 66138 i86_n3. This is a SolidWorks license server. The log says that the shutdown as requested by a user. How can this happen? I serached for some clues in the client and server event logs, no luck.

Help!

-Hhegde

xprt4y
06-08-2010, 10:28 AM
If you examine the license service in lmtools.exe...there's some advanced settings that prevent the license server from being shut down remotely.

Under lmtools.exe:

The tab titled "Start/Stop/Reread"

Click "Advanced Settings"

Then under [Start Server Options]...

Turn on/Enable {Restrict lmdown to work only from node where lmgrd is running }

hhegde
06-10-2010, 02:05 AM
Thanks for letting me know this, Xprt4y!
Unfortuantely, the interface customer using is a customized one for SolidWorks, and it does not have the option of forcing lmdown to operate only from the server. I can suggest the customer to use the generic 'lmtools' if the problem starts occuring more frequently.

xprt4y
06-22-2010, 08:44 AM
oops, didn't realize that they might not be using lmtools.exe

http://files.solidworks.com/Supportfiles/FlexLM_Enduser/licensingenduserguide.pdf

If they're using lmadmin....



Server Configuration - Stop Server

Stops the license server. Note that lmadmin’s default
setting enables this button, to disable it start lmadmin
with the -allowStopServer No argument.


Could it be this?