PDA

View Full Version : Two Problems : Install/upgrade and BDE



jdredd
04-28-2010, 02:54 PM
Finally migrated an installshield package made with express that came with Delphi 4.

Using the merge module for BDE, and would *like* for it to be not uninstalled, but it looks like it does, and from random posts on here, seems to be an issue.

it looked like BDE wasn't uninstalled in the old 1997 version, and would prompt you if you wanted to remove, and just click no to all.

I don't want BDE to uninstall as there could be (and has been) other apps then ours, that use BDE.

Has there been a sure fire way of making this happen? I dont really want to make a stand alone BDE installer, as this worked fine in the 1997 version.

Also the way the app is designed, If it is installed, is there a way to make it so the new install thats out, just overwrites whats there? No need to uninstall and then reinstall? Basically just need 1 install package, that doesnt matter if it was installed or not, it just does what it needs to, without having to uninstall the prev one first?