PDA

View Full Version : Requirement with Registry Key value



mtdave
01-04-2010, 03:52 PM
I am trying to set up an installation requirement that searches for a Registry Key value and continues if it is present, stops if it isn't. I am unable to get this to work.

HKEY_LOCAL_MACHINE>SOFTWARE>ESRI>ArcInfo>Desktop>8.0>.NET Support = TRUE

What is the correct procedure to do this?

Thanks, Dave
Tetra Tech, Inc.

jaybee96
01-05-2010, 09:13 AM
Use system Search
Create Property if found
Use Property in Launch Condition.

mtdave
01-05-2010, 11:30 AM
Thanks for the reply, I believe that is what I have been doing but I cannot seem to get it to find the key if it "is" there. I'll tell you step by step what I have done.

1) In the Installation Designer go to "#5 Define Requirements and Actions" and select "Requirements".

2) Right click on "System Software Requirements" and select "Create New Launch Condition (System Search Wizard)".

3) Select "Registry Entry" for "Choose the item you want to search" and click "Next".

4) On the next page select "Registry Root = HKEY_LOCAL_MACHINE" and under "Registry Key=SOFTWARE\ESRI\ArcInfo\Desktop\8.0\.NET Support" and then click "Next".

5) On the next page select "Installation will be allowed to procede if: Found". Enter a message for what to do if not found. Click "Finish".

Now when I build and run the setup.exe it never finds the ".NET Support" key even if it exists.

Is this not the correct procedure?

Thanks, Dave

jaybee96
03-10-2010, 11:40 AM
Hmmm.. What is the name of the Property you used?